Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

PGP Command line 9.8 & 9.9 on AIX 6.1 failing because of LIBPATH

Created: 11 Mar 2011 • Updated: 30 Mar 2011 | 2 comments
This issue has been solved. See solution.

We are currently using both 9.8 and 9.9 of PGP command line on AIX version 6.1.  We have another software installed that requires LIBPATH to be set to /usr/lib, first.  If not the software (Sterling Integrator) fails to start up and certain java processes will not run.

PGP seems to require, default installation, that the first path in LIBPATH be set to /opt/pgp/lib.  If its not we are unable to run pgp decryption/encryption, or simple stuff like ./pgp --version.  We have even tried installing pgp to a non default location and pointing the LIBPATH to /usr/lib:<new pgp library> but it still fails, because appartently PGP has to have its path set first.

We need a way to be able to run both programs.  Sterling Integrator has a command line option that will call the pgp executable but because its LIBPATH is set to /usr/lib, PGP fails with the following error:

stderr=Could not load program /usr/local/sterling/pgp/bin/pgp:
Dependent module /usr/lib/libiconv.a(libiconv.so.2) could not be loaded.Member libiconv.so.2 is not found in archive

Has anyone experienced this?  Is there a way we can have PGP use the libraries in /usr/lib?  Or is there a way to setup PGP to automatically look in /opt/pgp/lib before/during execution so that we can leave the .profile/.kshrc for our ID set to /usr/lib?  Let me know.  Thanks.

Comments 2 CommentsJump to latest comment

SDTSymantec's picture

Try implementing the following wrapper script for PGP Commandline and see if that works.

#!/bin/sh
PGPDIR=/opt/pgp
ulimit -n 2000
PATH=$PGPDIR/bin
LIBPATH=$PGPDIR/lib pgp "$@"

SOLUTION