Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

PGP Command Line is frozen- worked once after updating license key

Created: 14 Mar 2011 | 5 comments

PGP Command Line program is frozen. i updated the license key successfully after it expired   i successfully encrypted a file 

But later in the day it didn't encrypt. no error msg

I went into the cmd line and entered in a command to check the version and it just froze , no error msg no prompt.  this same command worked earlier

i've been using pgp successfully for 2 yrs.

any clues?

 

Comments 5 CommentsJump to latest comment

dfinkelstein's picture

That seems rather odd.  Can you provide some more details?

- What version of PGP Command Line are you running?

- On what platform?

- If you try running a command in local mode (with the "--local-mode" option) does it still freeze?

- Do all commands seem to freeze?  Do you eventually get a command prompt or do you need to kill the process or shell?

Thanks.

--------

David Finkelstein

Symantec R&D

John UZX's picture

running pgp 9.8  on windows server2003

we've been using PGP for 3 yrs on this server with no problems.

executing the command in local-mode works. i was able to display the version and all the details such as license key, etc

without local-mode  ALL commands freeze so I have to kill the process

Again, after I renewed the license and successfully updated the PGP with the update commands, i was able to encrypt a file, ONCE.

After that some scheduled code ran (been in production for 3 yrs) and the encryption process froze

??? any solution

 

Thanks,

            John G 

 

 

 

 

John UZX's picture

Here's some more details.

in the past 2 yrs a PGP tech assisted with the renewal license process. they entered the PGP command remotely on our server.

this year I did it.  I first entered the following renewal PGP command which didn't work:

pgp --license-authorize --license-name "removed" --license-organization "removed" --license-number "removed" --license-email “removed” --force

My name was in the original  PGP license details which I verified when I did a --version check.

I then called Symantec and the rep said to use the following command, which worked:

pgp --license-authorize --license-name "removed" --license-organization "Authorized Company" --license-number "removed" --license-email “removed” --force

 

Thanks for your help in this matter

John Graff

 

dfinkelstein's picture

Does the problem persist if you stop and re-start the PGP SDK service PGPserv, or if you reboot your system?

There have been some bug fixes to the operation of PGPserv since 9.8.  Is it possible for you to upgrade to the latest version of PGP Command Line?

--------

David Finkelstein

Symantec R&D

paulhen's picture

When the license was entered, two non-ascii characters were on either side of the email address. This caused the pgp process and pgpservice to hang. We updated the license information in the pgpprefs.xml, stopped the pgpservice (PGPserv), killed the pgp processes and then restarted the pgpservice. At that point all pgp commands worked as expected.

 Governments keep a lot of secrets from their people . . . Why aren't the people in return allowed to keep secrets from the government? --Philip Zimmerman, Der Spiegel