Video Screencast Help

PGP Deleted D Drive after Whole Disk Decryption

Created: 06 Oct 2012 | 6 comments

My 300 Gb Hard drive is partitioned into C and D drive. Each partition is 150 Gb. The disk is Whole Disk Encrypted and both drives have been accessible over the past year. After Whole Disk Decryption, D Drive no longer exists. If you navigate to Windows 7 Disk Manager you see that the entire 300 Gb is declared as C Drive. This is the strange part. If you open up windows explorer and right click on C drive and select properties, it still indicateds150 Gb. This tells me that D Drive is still there. Does anyone know how I can recover D Drive.

Thank You

Comments 6 CommentsJump to latest comment

Tom Mc's picture

I don't recall anything like this happening before, so am puzzled.  I expect decrypting your disk would return you to your previous state.  If both drives show in PGP Desktop, you may be able to just decrypt D:

When you consider your issue resolved, please click Mark As Solution on the most helpful response.

Search the Knowledge Base &

SparkyRay110's picture

I agree, it is puzzling; it is not something you would expect. The fact alone that windows seems to disagree with its self is something that is truly interesting. Unfortunately, in response to your post, D Drive is no longer listed in PGP. The only option that PGP always me to do is Encrypt C Drive at 300 Gb. When it was decrypted it the first place, it did list both drives as one selection at 300 Gb and proceeded to decrypt them and indicated that it successfully decrypted 300 Gb. Since I seem to have little option I am currently Encrypting the Whole Disk and hoping that it recovers D Drive.

 

Thank You for the quick response.

SparkyRay110's picture

After Encrypting Whole Disk, the same results. I have attached a screen shot of the situation.

D Drive Deleted by PGP.jpg
Alex_CST's picture

This is quite odd indeed.  First of all I would take any back ups now before you do anything that could result in you having to format, better to be prepared incase anything goes awry :)

After you've either imaged or backed up the HDD, you could use some bootable partitioning tools to investigate what the state of your HDD is outside of Windows, because it could be Windows itself who is getting confused.  If any app (partition magic for example) outside of Windows thinks its just 1 partition, you can then split it and see if it recovers itself.

I am guessing Windows has gotten itself confused after this decryption (god knows how) and maybe probing the state of the HDD or recovering the MBR via a bootable utility (once you have decrypted) could do the job.

Good luck!

Please mark posts as solutions if they solve your problem!

http://www.cstl.com

vaibhav_jain1's picture

This must be an issue with incorrect deletion of PGP User records from disk.

We have a somewhat similar issue fixed and scheduled to be released in Q1/Q2 2013.

Can you please check and post 0-63 sectors of the physical disk using a tool like dskprobe?

Do you see pgpwde01 etc files on your C:\ after decryption?(uncheck do not show protected system files in folder options and see)

 

 

SparkyRay110's picture

Unfortunately, the target system is my work computer and I needed to resolve this issue immediately. To that end I rebuilt a new hard drive utilizing my backup files and then went forward and encrypted the whole disk. Because this is a work computer, they are all configured the same way. I will try another system when a system becomes available and do a better job of tracking the before and after hard drive states.

Thank you for all your input.