Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

PGP Desktop 10.3.2 not working!

Created: 26 Mar 2014 | 14 comments

Hello there I have been a long time user of PGP on windows and it's always worked nicely aside from the issue where the damn thing posts unencrypted files top dropbox when it should be encrypted but whatever I'm not here to talk about that.

I recently got a Mac and wanted to setup PGP on it.

It has OSX Mavericks 10.9.2 I can install PGP just fine, create keys, encrypt, decrypt, sign etc etc however if I go to the PGP Disk section this error pops up:

§The system extension “/System/Library/Extensions/PGPwde.kext” was installed improperly and cannot be used. Please try reinstalling it, or contact the product’s vendor for an update.§

If I go to "Encrypt a Disk" no drives appear in the list not even my externals or USB sticks (all of which should appear).

If I do manage to make a volume I can't mount it usually and if by a miracle I do manage to mount it then it is lacking a ton of files that should be in the Volume it makes no sense at all.

I thought I might have installed something bad so I downloaded Mavericks from AppStore and installed it to a totally blank external drive and the FIRST thing I opened after the OS was installed is the PGP installer where I instantly installed it and got EXACTLY the same problems on a fresh install as I'm getting right now on my actual OS.

PGP 10.3.2 does 'not' work on a FRESH OSX 10.9.2 installation.

Is this going to be fixed soon? Since I am in the process of moving to Mac I will be changing all my drives over from NTFS to Mac and since I cant get PGP to work I fear I will have to use an alternative such as TrueCrypt but I really want to keep using my Public/Private key for my encrypted disks is there a way to make PGP work?

I can clearly tell that considering 10.3.2 does not work on a *clean* OSX 10.9.2 install that something is seriously wrong with the current version of PGP when can I expect an update?.

Thanks!.

Operating Systems:

Comments 14 CommentsJump to latest comment

Alex_CST's picture

I suggest upgrading all firmware on your device.  What type of Mac do you have?

Please mark posts as solutions if they solve your problem!

http://www.cstl.com

UberFoX's picture

It's a brand new 13" MacBook Pro Retina 512 GB SSD, 2.6GHz bought it just a week ago so I hardly think it needs firmware updates....

More Info says:

  Model Name:    MacBook Pro
  Model Identifier:    MacBookPro11,1
  Processor Name:    Intel Core i5
  Processor Speed:    2.6 GHz
  Number of Processors:    1
  Total Number of Cores:    2
  L2 Cache (per Core):    256 KB
  L3 Cache:    3 MB
  Memory:    8 GB
  Boot ROM Version:    MBP111.0138.B03

There are no updates available on software update.

Also I noticed there is no service to "encrypt this file...."  "sign this file..." etc which is also annoying forgot to mention in my first post.

Of course I've reinstalled PGP like 8 times and even installed it on a fresh OSX install and all this problems exist in both cases.

Alex_CST's picture

Do you use Bootcamp?

Please mark posts as solutions if they solve your problem!

http://www.cstl.com

aonris's picture

Seems to be PGP don't support Boot camp. Check that.
Beside check if you use FileVault.

Regards,

aonris's picture

Seems to be PGP don't support Boot camp. Check that.
Beside check if you use FileVault.

Regards,

UberFoX's picture

I don't use Boot camp and I am using FileVault BUT that's only on the drive Mac OSX is installed to.

My USB Sticks and external hard drives are not seen by PGP and they are not encrypted and are using the correct partition type and Mac OS file systems.

Alex_CST's picture

There are some articles on FileVault and PGP:

http://www.symantec.com/docs/TECH173502

Please mark posts as solutions if they solve your problem!

http://www.cstl.com

UberFoX's picture

That article is no use since everything is bootable just fine.

FileVault is only on the OS drive nothing else.

I'm not even trying to use whole OS encryption just virtual PGP drives and encrypt my external disks.

Having FileVault on main OS drive should not be a problem.

On windows I use TrueCrypt for disks and PGP for everything else and PGP has no problem making virtual disks and encrypting a usb stick... So the same should be true for Mac OSX

UberFoX's picture

OH about FileVault did you NOT read the part of my post where I stated I installed OSX to a CLEAN hard disk (without any file vault etc) and installed PGP there and STILL pgp didnt work?? Clearly FileVault is nothing to do with this.

Alex_CST's picture

You didn't mention FileVault whatsoever until it was brought up.

Open a support case.

Please mark posts as solutions if they solve your problem!

http://www.cstl.com

UberFoX's picture

Because as a programmer I'm not *entirely* stupid and I understood it couldn't possibly be FileVault for I had already tried a clean OS without FileVault activated in any way.

(TBF I actually used FileVault BECAUSE PGP was not working and after several hours of trying to get PGP working.....)

UberFoX's picture

I looked around and have seen the support for Mac users is terrible here.

I have had no choice but to use FileVault 2 (AES-256) on my main OS and the same for my externals just finished converting them.

I have also had no choice but to move to GnuPG because PGP simply won't work for me and at least GnuPG works and imported my PGP keypair with no problem.

I'm not sure what happened but I remember a time when PGP was the best been using it since my Windows 98 days back on PGP 6.

As for my windows computer it can remain with PGP since at least PGP works on windows but I had no choice but to find alternatives for Mac and that makes me sad that PGP has become like that and I know I'm not the only person with issues on Mac with PGP I have read this forum....

(Still willing to switch back to PGP if Symantec gets it together and makes it work on 10.9.2 properly)

UberFoX's picture

My friend just moved from Windows to Linux and found the same support from Symatec to be terrible for Linux.

We ended up having to install XP in a virtual machine and a create a hard drive link to the drive with encryption then mount the drive in the XP virtual machine and slowly copy files out it onto his Linux machine.

Needless to say after that painful experiance he won't be using Symantec PGP anymore.

Why do Mac and Linux users get shafted here?

PGP_Ben's picture

Hi Uberfox,

I'm on the Customer Engineering team. I'm very surprised by your post saying that you cannot encrypt the drive using Symantec Encryption Desktop on OSX 10.9.2 (Mavericks) we did extensive QA on this setup and it works for me. I have a 15" MBP Retina Display purchased 3 months ago. I use Filevault for encrypted disk images but can encrypt the boot drive with Symantec Encryption Desktop. I know we had some compatiblity issues with FileVault prior. It is supposed to detect if Filevault is in use and not load the WDE driver. Based on your post, it sounds like that is the behavior you are describing today.

What happens if you try:

ls -aln /System/Library/Extensions/PGPwde.kext

from within the Terminal.app application?

Does it list "no such file or directory"

It sounds like the Boot drive is encrypted using Filevault? Can you confirm that?

Or just non-encrypted boot drive when you go to encrypt? 

You are using Mac OS X (HFS) format on the external drives? or NTFS? I'm confused by a few of the comments in the post.

The Symantec Drive Encryption installation is supposed to detect if you have filevault in use and only disable the WDE driver for that volume itself. It also has a version detection which tries to find which version of Mac OS X you use and load either the signed or unsigned driver based on the version of Mac OS X. It sounds like something there is missing.

You could try this as a workaround (I would recommend backing up your data using Time Machine first before attempting these changes and burn a recovery image for Symantec Drive Encryption for Mac).

Open Terminal.
$ sudo su -
<enter user's password>
# mv /Library/Application\ Support/PGP/PGPwde.kext
/System/Library/Extensions/PGPwde.kext
# touch /System/Library/Extensions
# kextcache -v -u /
# exit

Since i'm not on the forums everday. You could always send me a PM if you have any questions.

Regards,

Ben

If/when you consider your issue resolved, please click Mark As Solution on the most helpful response.