Video Screencast Help

PGP Desktop can't open.

Created: 29 Aug 2012 • Updated: 03 Sep 2012 | 3 comments
PGPert's picture
This issue has been solved. See solution.

I have PGP Desktop 10.2.1 MP2 when I try to open PGP Desktop I get the PGP lock icon on the taskbar but no PGP Desktop window.  If I hover my mouse over the PGP lock icon on my taskbar, I get the image attached.  I've uninstalled PGP, manually, used CCleaner, reinstalled and same results. The PGP Options windows works, no errors appear on the PGP Log except a couple of proxy errors.  My system is Windows 7 Pro x64, NIS, Malwarebytes, Sandboxie, no other security product.  I saw another person with a smiliar problem back in September on this fourm, tried the suggested solution of removing PGPserv, but this service doesn't exist on my system.  Anyone help?

Discussion Filed Under:

Comments 3 CommentsJump to latest comment

Alex_CST's picture

Hi,

Assuming NIS = Norton Internet Security, please see the following extract from the 10.2 release notes:

 

Symantec Norton AntiVirus 9.x through 10.x, Symantec Norton Internet Security 2003, Symantec Norton Internet Security 2004
 
  • Disable email scanning.
  • For Norton Internet Security users, disable Norton Privacy Control and Spam Alert.
  • Disable SSL/TLS in Server Settings in PGP Desktop and PGP Universal Satellite. (In PGP Desktop, select the PGP Messaging Control Box and then choose Messaging > Edit Server Settings. For SSL/TLS, select Do Not Attempt. In PGP Universal Satellite, on the Policies tab, select Ignore SSL/TLS.) These versions of Norton AntiVirus prevent all mail clients from using SSL/TLS, regardless of the use of PGP software

NIS 2005+2006:

  • No special configuration required for MAPI email.
    When using POP email, enable Auto-Protect and disable the Anti-Spam and Email Scanning options.Auto-Protect, which is enabled by default, provides protection against viruses in email messages when the message is opened.
  • Disable SSL/TLS in Server Settings in PGP Desktop or PGP Universal Satellite. (In PGP Desktop, select the PGP Messaging Control Box and then choose Messaging > Edit Server Settings. For SSL/TLS, select Do Not Attempt. In PGP Universal Satellite, on the Policies tab, select Ignore SSL/TLS.) These versions of Norton AntiVirus prevent all mail clients from using SSL/TLS, regardless of the use of PGP software.
     
     
    Basically try uninstalling PGP Desktop, then NIS, then reinstall PGP Desktop and guage its functionality without NIS installed to confirm that is the thing at fault, then either do the remediation required or get a different version of NIS if possible

 

Please mark posts as solutions if they solve your problem!

http://www.cstl.com

PGPert's picture

Thanks weevil for taking the time to answer.  For a bit there, I thought this post would never get a reply.    

My version of NIS is ver 19.8 (NIS 2012) which is not listed to have any known issues in the release notes.  I should have posted earlier I solved the problem by reading some previous posts talking about issues with pgpdesk.exe.

I deleted the 2 xml files under C:\Users\User\AppData\Roaming\PGP Corporation\PGP (Win 7)

Apparently, if there are too many PGP Messaging profiles, it starts to impact pgpdesk.exe from opening or at least being visible.  I'd say maybe deleting PGPpolicy.xml might be good enough but it is too late for me to try that since I just deleted both xml files in that folder right away.

Once you deleted the files, reboot, you'll be asked to re-enter your product key.  PGP Desktop opens perfectly.  Your messaging profile list will be empty so you'll need to rebuild that again.  And no need to worry about your PGP keys, they are safe, plus there is no impact to WDE.

Just to add, I hope Symantec fixes the bug regarding those xml files.  I don't consider this a permanent or ideal solution, but at least it gets you moving forward for now.

SOLUTION