Video Screencast Help
Give us your opinion and win with Symantec! Please help us by taking this survey to tell us about your experience with Symantec Connect, so that we can continue to grow and improve.  Take the survey.

PGP Netshare transfer to new computer

Created: 29 Apr 2013 | 6 comments

I had netshare installed on a computer on the network and all worked just fine. I recently swapped out that computer for a different one and completed the following, but no luck in accessing PGP encrypted files:

installed Netshare
entered license key from original invoice
entered the name and email address associated to that license key
exported the keys to thumb drive
imported the keys to admin netshare computer
got the new computer to show "verified"
however when clicking on files that are pgp netshare encrypted i receive a pop up that says it's protected by one of the following 5 keys and it will not prompt for passphrase to gain access.

Operating Systems:

Comments 6 CommentsJump to latest comment

Tom Mc's picture

You apparently need to set your key(s) as having Implicit Trust.  You can do this by right clicking on your key in All Keys, selecting Key Properties, and selecting the down arrow by Trust.  If you can't set Trust to Implicit, you don't have the private key.  If you don't have the private key, you should export it again, and make sure that you select the option of including the private key in the export.  And then import again, with subsequently setting Trust as Implicit.

When you consider your issue resolved, please click Mark As Solution on the most helpful response.

Search the Knowledge Base &

backin2shape's picture

"include private key(s)" is grayed out during the export process.

Tom Mc's picture

Are you in a PGP Universal setting where this may not be allowed, such as by having keys in Guarded Key Mode?

When you consider your issue resolved, please click Mark As Solution on the most helpful response.

Search the Knowledge Base &

backin2shape's picture

not sure what that is.

after i get it to implicit do i need to add that user to every folder that's on the netshare from the admin user?

not sure why i'm having a difficult time with this, i've done it before.  

what's the best way to uninstall it and start over?  

is there anyway you can call me?

backin2shape's picture

I think i may have some info that would help:

I was able to get it to "implicit" but still can't access files here's what I did, tell me if i missed something:

1. exported the keys (blue keys) from the new machine, included privte keys

2. imported them into the admin computer's pgp desktop/pgp keys

3. added the new user to the folder in question under admin/pgp desktop/netshare

4. restarted the new computer and tried to access the folder from step 3 and didn't work :(

any ideas???

PGP_Ben's picture

What does your file sharing/NTFS file permissions on that share folder (on the Admins computer) look like? You need to ensure that your user account from the new computer is allowed to access that share.

If/when you consider your issue resolved, please click Mark As Solution on the most helpful response.