Video Screencast Help

PGP Universal Server decrypt messages problem

Created: 14 Nov 2012 • Updated: 16 Nov 2012 | 4 comments
This issue has been solved. See solution.

Hello,

I have a PGP Universal Server 3.2.1 Build 4940. It is configured as a mail proxy.

The problem is: We want to exchange emails with a partner who uses sophos mail gateway (gnupg). He can decrypt our messages fine, but we receive theire messages with a blank body and to attachments: One has no extension and contains only "Version 1". The other is a .bin-File and contains the encrypted message. I can decrypt it with a desktop program using our organization key.

The log says, the decryption rule is used: policy rule match: chain: "Inbound", rule: "Decrypt Message (SMTP)"

Does anybody know what causes this? Other recipients can communicate encrypted with us successful.

Thanks

Ralf

 

Comments 4 CommentsJump to latest comment

Alex_CST's picture

What is this desktop program that you are using to decrypt?

Please mark posts as solutions if they solve your problem!

http://www.cstl.com

Alex_CST's picture

I think there's a re pre-requisites for GPG to work with PGP

RSA key is being used, 2048 bit length (need confirmation on that bit length)

MD5 hashing algorithm

IDEA as symmetrical algorithm

 

Can you confirm all 3(4) are being used?

 

http://www.gnupg.org/faq/GnuPG-FAQ.html#how-can-i-...

 

Please mark posts as solutions if they solve your problem!

http://www.cstl.com

Weasel's picture

Solved it by creating a dummy user, give his public key to the sender and allow the appropriate consumer group to decrypt messages with this key.

SOLUTION