Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

PGP Universal Server settings lost after clustering

Created: 18 Dec 2013 | 1 comment

Hello everyone, while clustering two PGP Universal Servers I came across strange issue. I have two PGP servers that were running seperately as person who setp them up most probably simply forgot the cluster them. At first I tried to make server2 a cluster sponsor as this one was mostly used and server1 to join the cluster. Howeverm even though both are in the same network, they did not manage to form a cluster. So I tried to make server1 as cluster sponsor and make server2 joining. It worked like charm. And then the problems began. All configuration that was stored on server2 (users, keys...) was lost. I realised that when I was unable to use PGP Desktop. Re-enrollment did not work either, even though both servers reported no problems with connection to backing LDAP and users on PGP server were created, but without keys. Then I realised that except users and keys, also WDE devices and ingition keys were gone. I tried to recreate ingition keys, but it did not work as I received only error messages that ignition key cannot be created. Has anyone came across similar issue and could provide some hints? Thank you in advance!

Operating Systems:

Comments 1 CommentJump to latest comment

dcats's picture

Hi andrzejek,

Part of this behaviour is expected. The server which is joining the cluster will loose all its data. It is NOT possible to merge both databases.
If they have unique data which you require, the only solution is to keep them running in parallel until one of them is no longer needed.

If you have an Ignition key in place (one you need to unlock the server each time it is restarted), there is a chance that having attempted to sponser the cluster from both server may have messed-up the database.

Rgs,
dcats