Video Screencast Help

PGP US (SEM) Mail Routing

Created: 27 Aug 2013 • Updated: 03 Sep 2013 | 3 comments
Spinal's picture
This issue has been solved. See solution.

Working on a Symantec Encryption Messenger (PGP 3.3) server, and the mail queue is filled with this error:

Host or domain name not found. Name service error for name=gmail.com type=MX: Host not found, try again

Looking at the mail proxies, the server is set to

Send mail directly to recipient mailserver
 
Any ideas? It looks like I have a DNS issue, but I can't figure out what/where...
M.
Operating Systems:

Comments 3 CommentsJump to latest comment

Alex_CST's picture

So you're trying to send an email to a gmail.com address yes?

 

Have you set the DNS correctly on your universal server?

Please mark posts as solutions if they solve your problem!

http://www.cstl.com

Spinal's picture

Yes and yes - ended up figuring out the issue...

Nothing to do with PGP, and everything to do with ESX's settings... just a stupid routing mistake!

---

That said - I now have another issue. Set up a second server, popped it into the cluster and pointed one of the mai servers at it. Nothing. Double checked that I configured the mail routing and proxies properly on the second server, and it all looks good. To test, I tried sending a daily status email from the new server - and got an error. The following pops up in the log files:

 

    SMTP-00000: connection from 127.0.0.1:39834 closed   Wed Aug 28, 2013 at 16:09:30 +01:00
    SMTP-00000: connection to localhost[127.0.0.1]:10025 failed: Connection refused   Wed Aug 28, 2013 at 16:09:30 +01:00  
    SMTP-00000: SMTP connection from 127.0.0.1:39834 (local address is 127.0.0.1:2525)   Wed Aug 28, 2013 at 16:09:30 +01:00  

I'm curious as to why it is trying to connect to itself - the outbound SMTP proxy is set to "Send mail directly to recipient mailserver", as with the primary, which suggest the internal MTA isn't playing nice.

 

To troubleshoot connectivity, I logged into the secondary server via SSH, and did an mx lookup, but it's not that.

Next, I'm thinking postfix is the culprit here... but restarting postfix fails... not entirely sure why..

Executing /var/lib/ovid/customization/pgpsysconf-pre-custom.sh... success
Restarting service postfix... failed
Executing /var/lib/ovid/customization/pgpsysconf-post-custom.sh... success
 

Needless to say, I've tried restarting both the services and server...

Any ideas?
M.

SOLUTION
Spinal's picture

Update...

I know it is "bad form" to solve my own question but looking at postfix's logs, it became sadly clear that the issue was the FQDN of the server:

postmap: warning: valid_hostname: numeric hostname: <removed>
postmap: fatal: unable to use my own hostname
 

Changing the hostname to the correct one has instantly resolved the issue! Would be nice if the rest of PGP passed that message up without having to dig this deep.

 

M

SOLUTION