Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

PGP WDE Linux randomly fails with Error code -11977: improper initialization

Created: 19 Feb 2013 • Updated: 20 Feb 2013 | 1 comment
This issue has been solved. See solution.

Hi

I installed PGP WDE 10.3 on Linux as a standalone installation.
I authorized the software successfully.

The next steps from instrument, add-user and encrypt are managed thru a Java web server on the same machine.

After the system is setup to this license state

Calling instrument via Java the first time most often works but sometimes fails with

      "Error code -11977: improper initialization"

Once I could successfully encrypt the disk and afterwards decrypt it but then instrument failed again.

When instrument fails it always fails.

Also I known than calling the instrument command on the command line always worked so far, but the system normally has no console access.

 

The error looks random for me, but what does anybody know what could be the cause of it?

 

 

 

P.S: there seem to be no forum for the Linux version of the product, that's why I choose the Windows forum

Comments 1 CommentJump to latest comment

Alex 2013's picture

Found the reason,

It only worked when I start my Java web server from a terminal. But not when its started as a service on system boot.

SOLUTION