Video Screencast Help

PGP WDE Mac 10.1.1 Snow 10.6.6 and Virtual Disk Keys

Created: 25 Mar 2011 | 1 comment

Hi Guys 

I had to report a massive problem I encounter during my migration to 10.6.6. As expected  I upgraded WDE to 10.1.1 prior to upgrade snow to 10.6.6 (from 10.6.4)  WIth WDE 10.0.1 I had created lots of virtual disks and everything was ok prior to this 10.1.1 migration. I used to encrypt the virtual disks with my public key instead of the passphrase.. Then I upgrade to wde 10.1.1 and last uit not least osx to 10.6.6. The whole migration went right reboot ok no trouble. BUT as I tried to open the virtual disks nothing happens no error msg (even setting logging to debug in WDE). Using the command line tool pgpdisk an error msg was displayed (bad passphrase) In the logs  message is visible " trying with NULL passphrase" (if this could help the dev team..I would be glad). OK  I was not able to open all my virtual disks with WDE 10.1.1 and Snow 10.6.6 (nor with 10.6.7). An other error is creating a new virtual disk with this new setup using public key want work also, only creating with the passphrase works.. I don't know if I'am alone getting this error ??

Then I tried with WDE 10.0.2 and Snow 10.5.8 (an other machine) and guess what the virtual disks all open without problem (I had to move the keys also) THUS devTeam investigate this problem if I'm not alone ...Sorry but I don't know where the issue tracker is or where I can post a TT .

 

   

Comments 1 CommentJump to latest comment

sperrysymc's picture

The "easy" solution is below. However, this assumes you are not using WDE. You may need to enter your license key again so have that ready before you try this.

1. Hold Option and click the PGP Lock icon, choose Quit at the bottom.
2. Move ~/Library/Preferences/com.pgp.* somewhere safe. If something goes wrong, you can always follow these steps again using your old config.
To be extra cautious, copy (not move) your keys too. The default location is ~/Documents/PGP.
3. Start PGP again from Applications.

You will see prompts as if you had just re-installed. Answer you already have keys and select the location of the keys.

This should reset the keyring config. Now test your Virtual Disks. If they are still not working, you should really consider contacting someone in support.