Video Screencast Help

PGP Whole Disk Encryption and Windows Servers issue

Created: 28 Feb 2011

Hello,

I have been using PGP Whole Disk Encryption for a couple months now on our servers, and it works very well. We encrypted three portable hard drives to use as off-site backup storage, and have only had one issue so far. The server is running Server 2008 Datacenter x64, on a VMWare ESXi host server.

All of our servers are virtualized, including the file server that the portable drive is "connected" to. So we have to remote into them to manage them in any way. This is OK, the software runs fine and the HDD is ok. Everything's good. Except for if you connect the hard drive, before remoting into the server. What happens is, you press Ctrl+Alt+Del to log in, put in your credentials, and then the OS sits at "Welcome" with the spinning ring. I've waited hours and it never goes away. It seems to lock up the file system entirely because soon after I get complaints of people not being able to access the file server. We end up having to reboot the VM and then it works OK again. I can log into Windows, and then I have to reattach the drive, which then re-prompts for the password. Again, if I'm not logged into the VM before re-attaching the drive I run into the same issue again.

What I think is happening:
When you plug the drive in, PGP puts up a prompt for the password to unlock the drive. If you aren't remoted in, or if you weren't logged in (if it were a physical install. I haven't  tried this yet since we're all virtual) then you can't put in the password. trying to log in gets "stuck" because PGP probably locks either the file system or CPU calls or something to prevent you from viewing the drive. I'm not sure at all if any of my assessment is correct.

If I log into the server FIRST, and then hook up the drive, the password prompt comes up and everything is fine and dandy. This issue hasn't been such a problem since I found out how to get around it, but if I forget to log in first or I'm having someone cover for me who doesn't know to log in first, our file server comes to a grinding halt. I'm just wondering if anyone else has experienced this issue, and how they fixed it or what the deal is. I'm hoping PGP will put out a patch but since I don't have a support contract I'm left to bugging the community and hoping PGP happens to see my plight.