Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

PHP Errors Within Manager Console After Fresh Install

Created: 28 Jan 2008 • Updated: 21 May 2010 | 6 comments

I've installed SEP 11 on a Windows Server 2003 machine that is currently running IIS. I already have PHP 5.2.5.5 installed on it, because this server is running a few internal web-apps for our organization. After installing SEP successfully, I open the Manager Console and on the Home tab it displays PHP code rather than showing the tools. This happens for the Monitors and Reports tabs as well, but Policies, Clients and Admin all work correctly. The Manager Console freezes up often, even on the tabs that work correctly.

When I right click and "View Source" on the page for the Home tab, this is the PHP error message that is generated:

PHP Fatal Error: Class 'I18nLogin' not found in C:\Program Files\Symantec\Symantec Endpoint Protection Manager\Inetpub\Reporting\Login\Login.php on line 36

Under the Monitor and Reports tabs, there is no PHP error but instead the page times out. Please know that this is AFTER I log into the Console correctly.

Any help would be appreciated.

Comments 6 CommentsJump to latest comment

GrahamA's picture
Hi Kenneth,
 
I'd first suggest you review the following KB and ensure all IIS config checks out:
 
If it does, and no obvious cause arises, I'd suggest contacting Symantec Technical Support for further assistance, as it would seem you may be experiencing a genuine case of some type of conflict between an existing PHP install and the SEPM.



Message Edited by GrahamA on 01-28-2008 11:49 PM

GrahamA Product Management, Symantec Security Solutions

kenneth_d's picture

Hi Graham,
Thank you so much for replying. I did already check out all of the KBs that I could find on the topic, and all of the assessments suggested.

I will try contacting technical support... thanks

kenneth_d's picture

I think the issue could be related to the fact that SEPM installs its own version of PHP in the c:\program files\S\SEPM\Php directory.

Since I already have PHP running in c:\php, there are now two versions of PHP that are probably causing conflicts.

Is there any way I can disable Symantec's version of PHP and have it use the currently installed one? Or would I have to see if my web applications would run on Symantec's PHP?

I'd rather manage PHP separately from Symantec to keep consistent with my other IIS servers.

GrahamA's picture
The official support stance would be that SEPM would only be supported when using it's own PHP, I would imagine, since this is the environment that would have been QA'ed, beta tested, etc.
 
The best outcome here seems to be if we can get your PHP and the SEPM PHP to happily co-exist. I'll need to do some research into this.

GrahamA Product Management, Symantec Security Solutions

kenneth_d's picture

Ready for a twist?

Using the Data Sources (ODBC) tool, I cannot get the "Test Connection" button to return anything other than "Unable to start the database".

I -CAN-, however, log into the Manager Console and use the tabs other than the Home, Reports and Monitoring. I cannot log into the Manager Console from a remote workstation through port 9090, however - it downloads and installs the Java and Console, but I cannot log in.

I've verified there is nothing else listening on the same ports, and there are no other applications installed on this machine other than IIS web-based applications and file sharing.

I've tried all of the ODBC settings that I've found in the KBs - some of my attempts have broken the login to the Console, but when I put everything back the logins work - but never has the ODBC Test Connection worked.

I also tried installing on another Server 2003 machine - on a machine that did not have IIS or PHP installed. I installed IIS and installed SEPM - but on that machine I can't log into the Console at all. The issues with that machine is that it's running Websense which also uses a Sybase database (not sure the port#) and runs Apache to host its web services. For those reasons I didn't originally want to install SEPM on that machine, but figured I'd give it a shot. Same issues with ODBC as my original install.

I've also tried forcing Symantec to use my PHP-CGI.exe, and my PHP.exe, and even tried to use the ISAPI file to run reports. No luck. I've also tried to use the Symantec directory's PHP for all of IIS but my web apps break because of the lack of required extensions, different settings in PHP.INI, etc.

I do not have a version of PHP.INI installed in the Windows dir (like some PHP installation steps mention) and I tried removing c:\php from the system path to see if that helped - no go.

There are no errors that I've found in the IIS logs when I use the Console, either - but when I was messing with the different PHPs I did get Error messages instead of the pages.

IUSR_SERVERNAME has Read/Execute access to c:\PF\S\SEPM\Inetpub, as well.

What a day...

Zach 2's picture

So here is how I solved the reports, monitors, home, and policies tab issue.  Sometimes when loading the SEPM console, it would freeze after login or give a communication error. 

 

When you install the SQL client tools on the SEPM server, make sure there are no warnings.  I had to install a microsoft KB update to resolve a 'reporting component' issue with the SQL tools.  If you don't then the reporting features of SEPM won't work.  That was basically it.  I was going through this site modifying php and changing the service account yada yada yada and no luck.  Re-install the SQL client tools and see if you get a warning for one of the pre-req's.  If so, fix it and see if you have any luck.  Also, when installing the SEPM server, it did not set up the ODBC correctly - I had to change to the 'SEPMdba' SQL user - SEPM created the ODBC using my domain account.