Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Placeholder Service on Domain Controllers

Created: 25 Jun 2013 | 6 comments

I have just upgraded Vault fropm 9.01 to 9.04 R1

When I came to upgrade the placeholder service on the file servers two came up with an error and rolled back install. Error message was error 5 and seemed to be permissions error. I read some messages on forum about this happening with 9.04 when installed on domain controllers but none of the suggestions to fix this help. Eg copy msi to server and run from there add vault service account into domain admin group.

I have left the previous version of placeholder service on these two servers and they seem to be working OK

I did read that 10.0.3 had a placeholder service that allowed lower permission access.

Question is can I extract the agent from 10.0.3 software and install it on the two DC servers. Will it work ok with 9.04 at the back end?

Thanks

Operating Systems:

Comments 6 CommentsJump to latest comment

Darren Locke's picture

Actually, you can combine different versions of server and placeholder service - check out page 79 of the current SCL. The combo you want, EV 9 server with EV10 agent isn't explicitly listed and should work. I believe this is an oversite in the SCL but will check with the teams.

You do want the 10.0.3 placeholder service for correct operations on a domain controller (unless you have already granted the Vault Service Account domain admin privileges, in which case any version should work).

Darren

ronw's picture

I was under impression that I could use newer version placeholder services with older backend but could not find anything about it.

I have tried all the suggestions on the link provided none of he work. Same error 5

I also added the vault service account into domain admin group but as we are running bot FSA and Exchange archiving I seem to remember that the vault service account for Exchange cannot be a domain admin. Is that correct. Eitherw ay it would not let me install the agent so its not much help.

I am a little surprised that Symantec would have such restrictive install practices as it is common for smaller sites to have the DC running on the file server and if we cannot install agent we are in a quandry

JesusWept3's picture

I take it you did all the Run As Administrator stuff right? As it may just be a UAC thing

You could also try a procmon on the install and see where the access denied is coming from

ronw's picture

Thanks I could not get it working so resorted to using an older version of Placeholder service which worked fine.

Interesting side point I had to do another Domain Controller server recently so I applied 9.04 placeholder before running DCPROMO and that also worked. I understand that problme with UAC has been fixed in 10.x so will get around top that when I get a chance

Thanks