Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Please insert overwritable media.

Created: 20 Jan 2013 | 3 comments

Hello,

My enviroment consists of a HP StorageWorks Ultrium 1760 stand-alone drive...with which I want to backup a small number of servers (~10) mostly Hyper-V VMs...using BE2012.

My backup scheme is a B2D2T....So backup is done on a SAN disk atached to the BE server and then immediately duplicated to tape.

The schedule is simple...FULL backup every friday....differentials during the week. For this I have created 2 Media sets "Daily" with overwrite protection of 2 days....and "Weekley" with overwrite protection of 3 weeks...and both have append period set to infinite.

Now the problem is...all jobs start at 11PM...and they are automatically queued up to run one by one....but after a certain number of jobs....it just gives out the message "Tape "XXXX" is overwrite protected.......please insert overwritable media" (Sorry I can't reproduce the exact error message right now). And spits it out...

Does anyone know the reason for this?

There is no space problem....backups are rather small..so there are hundreds of GB left on the tapes.

Tapes are all brand new LTO4...I tried either with tapes that I had pre-associated to the media sets I created...and with never touched tapes (scratch media), and the behavior is the same.

What I would expect from this setup is that backups would be appended to the tape till no space is left..and since I have rather small size backup..even If I were for some reason to leave the same tape in the drive it would still have space to do backups for at least a few weeks...but yet it just fails after a few jobs wanting other overwritable media.

I checked and on some ocasions the tapes would end-up as beging "End marker unreadable"...so in that case it's clear why it couldn't append data to them..but in most cases the tapes would be fine..with append period marked as "Infinite" and yet it would spit them out and request overwritable media.

I`ve been searching for a solution for a few days but haven't managed to find anything so any help would be hugely appreciated.

Thanks, 

Comments 3 CommentsJump to latest comment

pkh's picture

1) Click on the BE button ---> Configuration and Settings ---> Backup Exec Settings and check that you have these settings

2)  It is not clear from your post, how many jobs that you have a day and whether you use one tape a day for your daily job or one tape a week for your daily job.

3) The first job in the stream should specify overwrite and the rest of your jobs should specify append.

4) Some of the reasons why your subsequent jobs are not appending to your tapes are given in my article below, in particular note the part about overlapping jobs.

https://www-secure.symantec.com/connect/articles/w...

st3reo's picture

Thanks for your reply,

I have separate tapes for each day. I have a single job for each server..so about 10 jobs that run each day at 11 PM. All the settings seem to be ok.

After some more testing I think I figured out  why it was ejecting my tape.

I had some jobs that belonged to different Media Sets...and it seems it would run the jobs from one of them (whichever happened to be first...and automatically associated the tape with the respective media set) and when it got to the jobs that had to be done on another media set it would eject the tape and request an overwritable one.

As far as I know...for the sake of continuity...if it does not find an overwritable tape in the correct media set it can use one from another media set....this is true for overwriting...but does not seem to be true for appending...If a tape belongs to a media set it will only append to jobs from that media set....I was under the impression that it would append any kind of jobs as long as the append period permitted it.

Could you please confirm this?

So I guess my initial theory that if I were to leave a tape inside for a longer period and have it append all the jobs to it...is false...since on the first ocasion it would need a tape from a different media set it would just eject it and the whole process would come to a halt.

And could you please detail a bit on the "first job in the stream should specify overwrite and the rest of your jobs should specify append" part....

Thanks a lot,   

pkh's picture

When a job overwrites a tape, the tape would be associated with the media set targeted by the job.

When a job tries to append to a tape, it would look for a suitable tape in the targeted media set.  If it cannot find a suitable tape, it would either fail or switch to overwrite mode, depending on the job setting.  In your case, the tape in the tape drive belongs to another media set, so the job which targets a different media set cannot append to it.  Apparently, your job switches to overwrite mode.  It then find that the tape in the tape drive is not overwritable because the OPP of the other media set is in force.  Your job then eject this tape and requests for an overwritable tape.

The "first job should overwrite ,," bit is to ensure that you are using the maximum capacity of the tape.  If you specify append for the first job, it will just use the remaining free space on the tape which might not be enough for all your jobs.

You should consider getting a tape library.  It would solve a lot of your problems.