Video Screencast Help

Pre cache ICON - option does not work

Created: 13 Feb 2014 | 11 comments
bold's picture
Hello! 
 
We want to use Pre Cache option - icon, but it does not work. The only option for the user to stream application - is to open portal and choose an application from there. After that the application is streamed and the application icon appears on the desktop. But the icon never appears before the application streams, even when the option to pre cache icon is selected.
 
How this can be solved?
Operating Systems:

Comments 11 CommentsJump to latest comment

Joseph_Carson's picture

Hello,

just checking on how your created the virtual package?  Did you use SVSAdmin or Virtual Composer, did you create the Streamlets and Shortcuts using Virtual Composer.  Did you select the package defaults to be Icon on upload or did you change those after uploading the package?

Lastly just checking which version you are using?

Kind Regards,

function DOMContentLoaded(browserID, tabId, isTop, url) { var object = document.getElementById("cosymantecnisbfw"); if(null != object) { object.DOMContentLoaded(browserID, tabId, isTop, url);} };
function Nav(BrowserID, TabID, isTop, isBool, url) { var object = document.getElementById("cosymantecnisbfw"); if(null != object) object.Nav(BrowserID, TabID, isTop, isBool, url); };
function NavigateComplete(BrowserID, TabID, isTop, url) { var object = document.getElementById("cosymantecnisbfw"); if(null != object) object.NavigateComplete(BrowserID, TabID, isTop, url); }
function Submit(browserID, tabID, target, url) { var object = document.getElementById("cosymantecnisbfw"); if(null != object) object.Submit(browserID, tabID, target, url); };

bold's picture
Hello, Joseph!
 
We create packages in Virtual composer. 
After the capture process - during which a shortcut is created for the application on the desktop (winzip, adobe professional) we do not make any changes to virtual package.
Version is 7.5.0
 
 
Best regards,
Ilya
Joseph_Carson's picture

In Virtual Composer can you check that a shortcut is created, not the one on the desktop.  You will see a shortcuts tab within virtual composer.

Kind Regards,

delvalled's picture

Hi Ilya,

Please reboot one of your client machines, login as a user that has been provisioned to an application that has been set to pre-populate the icon or package, and then collect the most recently modified streaming client log (MgrLog.txt) under C:\_AC\logs. The client log should reveal any errors communicating with the primary server when performing the pre-population check and should help us determine next steps.

bold's picture
Hello! 
 
The option to create shortcuts is set. See the attached screenshot. 
 
And also I attached the client logs. 
 
 
Thank you!

 

 

1.png
AttachmentSize
MgrLog4.txt 6.69 KB
ateamrh's picture

Hi Bold,

Just a quick question, have you enabled slam in the appstreamcfg.txt file on the client?

Kind Regards

Martin

Oberholzer's picture

Hi

We have the same problem.

When we start an application from the portal and reboot the client machine, the precached icons are visible in the startmenu.

Also for other users who login to the client machine.

Kind regards

Oliver

ateamrh's picture

Hi Oberholzer,

It seems like your application is set to start on system startup and that you have not enabled slam in appstreamcfg.txt on the client.

Uncomment the 2 slam options in appstreamcfg.txt in the streaming\bin folder on the client and reboot.

SLAM stands for Symantec Layer Activation Manager, and this activates and deactives applications based on  the users provision.

Kind Regards

Martin 

 

ateamrh's picture

Please accept an reply as the solution if it fixed your issue.

If not then please provide more information.

Kind Regards

Martin

Oberholzer's picture

Hi Martin

Thank you for your help. Your solution work for us.

Another effect is, our VDI environment is more stable with this setting.

Kind regards,

Oliver

 

ateamrh's picture

Hi Oliver,

Glad it helped you.

Kind Regards

Martin