Video Screencast Help

Pre-OS Drivers and AHCI Windows 7 x64

Created: 08 Aug 2013 • Updated: 30 Aug 2013 | 15 comments
This issue has been solved. See solution.

Hello,

We’re currently having troubles with Ghost and AHCI and I would appreciate some help.

Ghost server: 11.5.1.2266

Workstation OS: Windows 7 x64.

Worstation brand: Lenovo ThinkStation and ThinkCentre

Since we’re starting to receive workstations with SSDs, we decided to move from IDE to AHCI in our installation standards. As they say… better late than never.

I’ve build a WinPE including the basic AHCI driver in GBW and added a few more (ICH09 and ICH10) to cover some exceptions.

Since the previous Windows installations were no longer booting correctly after changing the SATA setting from IDE to AHCI in the BIOS, we opted to wipe every disks and deploy a Ghost Boot Partition created from the new WinPE mentioned earlier.

There were no driver errors and the deployment prooced without any problems.

Unfortunately, when we run a console task on the newly deployed workstations, the task fail without ever booting in WinPE. The error in the Ghost console mention that the AHCI Controller drivers in the Pre-OS could not be found.

Other errors are referring to Intel C600x79 series chipset 6-ports SATA AHCI controller and SAS Controller for Lenovo ThinkStations S30.

However, this problem doesn’t seem to affect workstations running Windows 7 x86.

Since we did not experience this problem with the Ghost Boot Partition (Vista x86) in the original deployment, is it necessary to include the x64 version of any AHCI controller or chipset drivers in WinPE to prevent this kind of problem?

Thank you

Operating Systems:

Comments 15 CommentsJump to latest comment

Terry BU's picture

the PE is Vista 32bit.  When the task fails "to virtual partition" you can double click it and get the PCI\VEN_XXXX&DEV_YYYY string.  that will tell you what devID is missing.  You may be missing something really dumb and ghost will still complain (though it is usually storage or NIC).  Add that driver (again, Vista 32bit) and make sure you check it in the box!  rebuild, and try restoring it again.

StephC's picture

Hello Terry.

Tanks for the reply.

That’s pretty much what I could gather.  I’ll take note of the exact string and write in in my next post.

But, none of these errors appeared when we were in the Pre-OS environment prior to deployment (Ghost Boot Partiton) and it’s only happening so far with workstations running Windows 7 x64.

I tried reinstalling the Ghost Client on a few computers affected by this problem just in case some drivers did not installed correctly and the problem persists.

I’ve checked the content of our new Win-PE and every AHCI controller (standard, ICH09 and ICH10) inside are checked.

My question remains. Since this problem is only happening on x64 workstations, do I need to install the Windows 7 x64 AHCI drivers in the Win-PE package for x64 workstation to reboot correctly in the Ghost Partition when running a task from the console?

Terry BU's picture

the only drivers that matter are the Vista 32bit drivers since those are the only drivers the PE will use (it being Vista 32bit)

sometimes you will see that forcing a boot partition and rebooting will work (and work great!) but booting from windows into the virtual partition from the console will fail.  Its annoying.  it may be asking for a USB driver.  i have seen that.  I had one keep asking for C216 drivers, and it didnt even fail on every machine in the group!  and to fix that i had to get Server 2008 drivers, since there were no Vista drivers available!

i think you have a "missing" driver that only matters to some of them.  and once you get it, it will probably work.

EdT's picture

While doing build work a couple of years ago, I wrote a little utility that records all the plug and play IDs in a system, into a text file. The code is articled here: 

https://www-secure.symantec.com/connect/articles/readyutility-assist-identifying-plug-and-play-drivers

I used to run it from any installed Windows operating system - usually the vendor's preload, before I wiped the hard disk and installed the corporate image. Having all the PNP IDs and an indication of the driver INF files and the device name was a great help in tracking down the right drivers from the internet.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

StephC's picture

Thanks EdT.

I'm leaving work in a few minutes. I'll update this thread on monday.

StephC's picture
Sorry for the lack of updates, but i was assigned to other tasks for a while.
 
I’ve downloaded the drivers from intel (https://downloadcenter.intel.com/Detail_Desc.aspx?...) and added them to our new WinPE. All of the S30s are booting correctly in PreOS and no more C600x79 series chipset 6-ports SATA AHCI controller and SAS Controller errors.
 
Unfortunately, the same cannot be said for the basic Standard AHCI 1.0 Serial ATA Controller error that we are experiencing on most workstations (ex: Lenovo ThinkCentre M91p).
 
Like I’ve said previously, installing the Intel drivers for ich09 and ich10 did not solve the issue. I’ve also added the driver in this thread (https://www-secure.symantec.com/connect/forums/can...), but no dice.
 
I’ve run the script suggested by EdT and here is the entry related to our error
 
Manufacturer: Contrôleur Serial ATA standard AHCI 1.0
Name: Contrôleur Serial ATA standard AHCI 1.0
Description: Contrôleur Serial ATA standard AHCI 1.0
Class GUID: {4d36e96a-e325-11ce-bfc1-08002be10318}
PNP Device ID: PCI\VEN_8086&DEV_1C02&SUBSYS_307017AA&REV_05\3&11583659&0&FA
Device Class: HDC
Hardware ID: PCI\VEN_8086&DEV_1C02&SUBSYS_307017AA&REV_05
Inf Name: mshdc.inf
Service: msahci
 
If I use Driver Extractor on said controller, the following files are related:
atapi.sys
ataport.sys
msahci.sys
mshdc.inf
pciidex.sys
StephC's picture

Added screenchot of the error in the Ghost Console

Error L4480.png
EdT's picture

Try googling on the PNP ID:  PCI\VEN_8086&DEV_1C02&SUBSYS_307017AA&REV_05\3&11583659&0&FA

Make sure you are providing Vista 32 bit drivers.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

StephC's picture

Already did.

Didn’t find anything relevant.

I’ll keep looking

EdT's picture

I have a feeling that the basic WinPE V2 configuration should natively support the Serial ATA standard AHCI 1.0 standard, as the Vista operating system natively supported the first generation of SATA chipsets.

It may be worth a quick test with a basic WinPE boot device on these machines to check whether the hard disk is accessible without adding drivers at all.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

StephC's picture

What is this WinPE V2 you are referring to?

There is no error messages and the hard disk is accessible when I use a BootCD or deploy a Boot Partition.

I get this error only when I run a console task on a workstation that already has Win7 x64 installed.

I’ll try using the default WinPE and post the results.

Terry BU's picture

WinPE is the small windows installation that GSS makes the computers boot into while ghosting them.  it looks like Windows, but not as functional.  v2 means it was built off of Vista (this is the one GSS uses, which is why you always have to get 32bit Vista drivers).  v3 is Win7, v4 is Win 8.  v1 was XP

StephC's picture

Thank you Terry. I was under the impression that I somehow missed a GSS update.

Terry BU's picture

reading that made me laugh.  There have not been updates to GSS that you didnt have to call and get emailed in some time.  Then i sad faced because its true

 

Glad to help though

StephC's picture

Yeah, I can relate Terry. /sadface

Ok, i had to resort to downloading chipset drivers from Lenovo’s website.

I would have preferred finding the exact one I needed from Intel’s website, but at this point I can’t be picky.

After adding the chipset driver for ThinkCentre M91p (4480), it covered all of the other models we had AHCI driver errors.

Thanks for the help!

SOLUTION