Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Prerequisite check IIS_SP3 error SSR 2013 Management Solution

Created: 24 Jan 2014 • Updated: 28 Jan 2014 | 9 comments
This issue has been solved. See solution.

Colleagues!
I'm trying to install System Recovery 2013 Management Solution.
Installing the System Recovery 2013 Server Edition application always successful, but...
I getting IIS_SP3 error during prerequisite check (last SIM version) for System Recovery 2013 Management Solution.
Tested on two different hardware servers. OS Windows Server 2008 R2 Std SP1 x64 + all hotfixes.
There is no information about this error in the network

Has anyone encountered error IIS_SP3?

P.S. Screenshot in attached file

Operating Systems:

Comments 9 CommentsJump to latest comment

Chris Riley's picture

Could you please translate the error message into English? wink

Also, please confirm the version of Symantec Management Platform (SMP) you are trying to install using SIM.

Boozy's picture

Thanks for quick reply!

Translation:
IIS_SP3 Prerequisite check - Error
Unable to perform prerequisite readiness check IIS_SP3.

Components selected for installation:
Symantec System Recovery 2013 Management Solution x64 SP1 (11.0.1)
Symantec System Recovery 2013 Installer x64-x86 SP1 (11.0.1)
Symantec Management Platform 7.5 (automatically selected by the SIM)
Languages Symantec Management Platform 7.5 (7.5.1670) (automatically selected by the SIM)
Altiris Documentation Languages 7.5 (automatically selected by the SIM)

Chris Riley's picture

I'm not sure what is causing that error but I can confirm that SMP 7.5 is currently not supported with the SSR Management Solution:

http://www.symantec.com/docs/TECH211862

You need to install SMP 7.1 instead of 7.5.

Hope that helps.

Boozy's picture

I tried install only SMP 7.1 SP2 MP1 with complete IIS reinstall, using this instruction: https://www-secure.symantec.com/connect/articles/h...
And the same error IIS_SP3 all the time.

Complete IIS uninstall IIS command is: start /w pkgmgr.exe /uu:IIS-WebServerRole;WAS-WindowsActivationService

SIM log exeption:
( Exception Details: System.NullReferenceException: object reference not set to an instance of an object.
   in InstallReadinessChecks.IIS_SP3.RunInstallReadinessCheck(InstallReadinessCheckStrings& installReadinessCheckStrings, Hashtable stringResources)
   in Symantec.Installation.InstallReadinessCheckRunner.RunCheck(IList`1 selectedComponents) )
( Exception logged from:
   in Altiris.Diagnostics.Logging.EventLog.ReportException(Int32 severity, String strMessage, String category, Exception exception)
   in Altiris.Diagnostics.Logging.EventLog.ReportException(String strMessage, Exception exception)
   in Symantec.Installation.InstallReadinessCheckRunner.RunCheck(IList`1 selectedComponents)
   in Symantec.Installation.Context.WizardProcess.ReadinessCheckManager.DoInstallReadinessChecks()
   in System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   in System.Threading.ThreadHelper.ThreadStart()
 )
( Extra Details:  Type=System.NullReferenceException Src=u9swe5gv )]]></event>
<event date="Jan 28 11:35:18 +00:00" severity="1" hostName="HOSTNAME" source="Symantec.Installation.Context.WizardProcess.ReadinessCheckManager.DoInstallReadinessChecks" module="SymantecInstallationManager.exe" process="SymantecInstallationManager" pid="2600" thread="13" tickCount="1693718"><![CDATA[PerformInstallReadinessCheck - InstallReadinessCheckException occurred while executing test IIS_SP3

( Exception Details: Symantec.Installation.InstallReadinessCheckException: Exception occurred while executing RunInstallReadinessCheck ---> System.NullReferenceException: object reference not set to an instance of an object.
   in InstallReadinessChecks.IIS_SP3.RunInstallReadinessCheck(InstallReadinessCheckStrings& installReadinessCheckStrings, Hashtable stringResources)
   in Symantec.Installation.InstallReadinessCheckRunner.RunCheck(IList`1 selectedComponents)
   --- End of inner exception stack trace ---
   in Symantec.Installation.InstallReadinessCheckRunner.RunCheck(IList`1 selectedComponents)
   in Symantec.Installation.Context.WizardProcess.ReadinessCheckManager.DoInstallReadinessChecks() )
( Exception logged from:
   in Altiris.Diagnostics.Logging.EventLog.ReportException(Int32 severity, String strMessage, String category, Exception exception)
   in Altiris.Diagnostics.Logging.EventLog.ReportException(String strMessage, Exception exception)
   in Symantec.Installation.Context.WizardProcess.ReadinessCheckManager.DoInstallReadinessChecks()
   in System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   in System.Threading.ThreadHelper.ThreadStart()
 )
( Extra Details:  Type=Symantec.Installation.InstallReadinessCheckException Src=SymantecInstallationManager

Boozy's picture

I already tried to install SMP 7.1, but got the same error. I'll try again with complete IIS reintall.
I'll let you know the results.
Error can be skipped if you click back button and then again next.

David.Balsa's picture

hello,

 

I have the same problem with SIM 7.5 Asset Management 7.5.

Prerequisite check IIS_SP3 - Error
Unable to perform prerequisite readiness check IIS_SP3.

 

Boozy's picture

SOLVED!!!
I found "unexpected end of file ResX" in SIM logs during prerequisite check (near IIS_SP3 error).
The solution was to change the format (Russian for me) on English (US) in "languages ​​and standards".
Special THANKS* for developers!

SOLUTION