Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Preventing Repetitive Backup jobs on same week.

Created: 01 Jul 2013 • Updated: 03 Jul 2013 | 10 comments
This issue has been solved. See solution.

Before upgrading to BE2012, BE 2010 was in use.  However, due to Oracle agent issues it was recommended to upgrade to 2012, so we upgraded.  In BE 2010, there are jobs setup to run weekly on Mondays.  These jobs were set based on the 1st, 2nd, 3rd, 4th, and 5th Monday of the month.  After upgrading to 2012, I found some backups taking 24+ hours to run, so I dug into it and thus found the issue is with the backup jobs based on the week, first, second, third, fourth, and last Monday.  The 5th option was changed to LAST. Well as you can see in the included attachment, there are jobs that repeat, notice the 8pm and 11pm hours there are two different jobs but repeat.  The job set as the 4th Monday of the Month and then right after the 5th or “LAST” Monday during a 4 week month runs.  Of course the second job is not needed.  I attempted to edit out the repetitive job by right clicking on the job and choosing “Exclude,” However this action removed all the jobs for the day.  Does anyone have any suggestions on how to best address this?   Thanks... 

Operating Systems:

Comments 10 CommentsJump to latest comment

Donald Eady's picture

I noticed that the jobs are not scheduled to run at the same time... if you configure your jobs to be stages within the same backup definition/job and set them to begin at the same time then the least run job will supercede the more frequently run job

 

please see below 

 

Edit : forgot to post screen shots... see below 

 

 

1st monday.JPG 1st monday supercede.JPG

I hope this posting was helpful

  

SOLUTION
GWL_WilliamsburgIT's picture

Thank you Donald for the quick response.  Yea, I do recall seeing in the calendar my filer backup with Supercede showing the the Job Schedular.  I think I understand what needs to be done and will adjust my jobs to match your recommendations.  I will post the results in a day or so.

Donald Eady's picture

Looking at screen shot again it looks to me as if you have configured five individual jobs to run throughout the month and not the one as i suggested above. The above suggestion should remedy the issue. 

I hope this posting was helpful

  

GWL_WilliamsburgIT's picture

Ok, things are looking good, but if I have a job, see attached, that does not show Superseded, then that means there is something in the job that is not set the same correct?  I have at least one so far that does not show superseded.

Thanks

va-backup schedule.jpg
Donald Eady's picture

If they are a part of the same job and scheduled for the same time... on should be superceding the other... even if there are differences in the job.. I.E. one is a full and the other in an Inc... Im not sure why the job set to kick off at four is not being superceded.. Please verify that the two job are not stages of two seperate job s.

I hope this posting was helpful

  

GWL_WilliamsburgIT's picture

I have looked over the job settings and verified, both are part of the same job that runs on Sunday.  Both can be seen in the screen shot and are the same... And I am not sure why BE keeps changing the order of the jobs.  It was in cronilogical order until I put the Fifth one in.  And after saving BE moved Fifth to the top.

va-backup sep.jpg
Donald Eady's picture

Scratching my Head GWL,

 

       Have you tried recreating the job to see if you get the same result. ?

I hope this posting was helpful

  

GWL_WilliamsburgIT's picture

Not fully recreating, not yet.  I deleted all the job entries but one and tried, no joy.  So next is fully deleting and building from new.  I might even try going backwards since the order does not seem to matter.  I will try building Week 5 and 4 first and seeing what it does... 

In another job I have the same issue, however, it is set for all FULL jobs to run at 10am and any Incremental to run at 6pm.  Yet the Superceded is not working there either, I have to pick a single time for it to work on this one as well correct...

Donald Eady's picture

You dont even have to delete the job right off... you could just create another job title it sunday va test. Mimic the selection list mimic the schedule change the times from 4 to say 6/or 7 since there are not jobs at those times and then view the calander. 

in regard to your other job if you are expecting the full to supercede the incremental then yes the jobs have to be scheduled at the same time

I hope this posting was helpful

  

GWL_WilliamsburgIT's picture

Wanted to let you know that your solution all around Donald was exacly what I needed.  Using the Superceded looks to work as I need it to.  With the one va-sep job that would not show Superceded, I created another backup job as you indicated and that one did show as it should.  In fact doing so also seemed to fix the original va-sep job so it too now shows Superceded.  I have deleted the test job and we are still good. 

Thanks you Greatly  :)

 

Another question thought, looking at the screen shot above with the schedule, the last job listed is va-salto.  Why is that one not all the way to the left?  It is like it is floating.  This is one thing I have noticed with the Superceded, any job that is suppose to to superceded but does not is showing like this.  Once the job shows all the way to the left, then superceded shows up as it should...   Very odd...