Video Screencast Help

Printmig.exe and printbrm.exe cannot read .cab

Created: 20 May 2009 • Updated: 21 May 2010 | 3 comments

Hello all,

We are quite busy creating a Altiris enironmentfor deploying software to all hardware our company uses.
Now we have this strange thing. We want to migrate printers (local on HP6710b laptops with Vista Business. Printqueues print directly to printer ip adresses on purpose because of large jobs)  so we used Microsoft Printer Migrator 3.1 to backup printers from 1 laptop.  We named the exported .cab file: 7655.cab

Now, what we do is this: The Altiris job first task is to cope a directory wich containes the printmig.exe and the 7655.cab to the client laptop on c:\swsetup\printerinstall.
Then the job runs a scripts wicht has the folowing string in it: 
call c:\swsetup\printerinstall\printmig.exe /r 7655.cab
this script uses a domain admin account to run.

Waht we see is that Altiris says the script executed succesfully but on the client laptop we don't see the printers. I found the reason why: If altiris runs the script the printmig.exe starts to work. But there is a point prinmig stops the printqueue and then wants to access the 7655.cab. At that point the printmig.exe stops, quoting: unable to open 7655.cab

Now the 'funny' part starts.. If we open a command prompt on the client laptop and we type the same command (c:\swsetup\printerinstall\printmig.exe /r 7655.cab) then it works great and we get our printers back just the way we want.

We tryed several thins: we started the client laptop without logging in and then started the job, we started the job with a domain admin logged in, and we started the job with a normal user logged in. The script always gets stuck when it has to acces the 7655.cab

Now there is a printer migrator especially for Vista: printbrm.exe
Also with this program we experience the same problem: it cannot open the cab file (with printbrm we made a new .cab file off course) and it works fine if we start it locally.

So my question is: Does anyone know if Printmig.exe and/ or printbrm.exe have known issues with Altiris? Or has anyone experienced the same problem maybe and how did they solve it?
All tips are very welcome!

Thanks in advance,

Sander Krol
Infotechnology
Hillegom, The Netherlands

Comments 3 CommentsJump to latest comment

skrol's picture

 I now realize i might have posted this on the wrong topic..
maybe the admins can move this to the right spot if this is the case

TheSmiz's picture

-- What type of script are you running, vbs, perl, batch file?
-- How is your script executing printmig? (what type of exection, wsh.run, wsh.exec, shell, start...)

skrol's picture

I'm using no particular script. In Altiris, when you add a task to a job, you can choose 'Run Script'. Then, in the first screen of that wizard, choose the option: 'Run this script'. In the text area i put the following commandline (including commandline parameters):  
 
call c:\swsetup\printerinstall\printmig.exe /r 7655.cab

I also tried printbrm (for Vista). That commandline is this:

call c:\swsetup\printerinstall_vista\printbrm.exe -r -f 7655.cab

Now, none of those worked out as you could read in my first posting. I also tried to copy a .bat file to the laptop wicht had the same commandline. Then i tried to run the batch file, but all options show the same result.

I think it has got something to do with the Vista security. Because if you run this on any XP machine, it works just great!