Video Screencast Help
Give us your opinion and win with Symantec! Please help us by taking this survey to tell us about your experience with Symantec Connect, so that we can continue to grow and improve.  Take the survey.

Problem accessing archived items from OWA after upgrade

Created: 15 Nov 2012 • Updated: 26 Nov 2012 | 11 comments
This issue has been solved. See solution.

Hi all!

I have upgraded my EV 9 to EV 10.0.2 with external help.. Done this by installing new 2008R2 server and using export/import.

After this all Outlook client work fine but we cant access archived items from OWA Exchange 2007SP2 CAS/HUB NLB.

Been digging arround a bit and found that I cant find the EVAnon virtual site in IIS and alos found some missing IIS roles compared to the old 2008  EV server.

We deployd this night and still havent a full it safe to install the missing roles and run the OWAUSer.wsf to fix the OWA problem wihout any risk of the new/moved data?

have also run the EVORT att one CAS/HUB and got this..Failed Virtual Directory information could not be obtained.

Thanks in advance!


Comments 11 CommentsJump to latest comment

Rob.Wilcox's picture

In my opinion ..

a/ get the backup done first.

b/ get the external help back to 'fix' the problem

c/ additional rules, and the owuser script seem like the way forward.

Krister's picture

Thanks Rob!

whait untill the fullbackup is done this weekend and then I try the steps

Krister's picture

Well well. have now made the settings in IIS and run the OWAUSer.wsf and made a sync.....

The Evanon site was created and it looks good.... BUT...still doesent work from OWA

Any more tip?



Krister's picture

Anyone know if it is nesesary to publish EV in ISA from version 10 of EV? In version 8 and 9 it worked without.

wandarah's picture

I'm not sure about that, I've always had to configure ISA in 8 and 9. 

I've not had the situation in which I needed to do so for 10, so far - but I'm assuming it'll be the same. 

Chau Tran's picture

For ISA it depends if you need to access the archived items from external or not. If EV is for internal use only then there is no need for ISA. Exchange 2007/2010 and now exchange 2013, it is recommended that you use ISA/TMG/UAG for external use due to the fact that Search and Archive Explorer connect directly to the EV server and not through the CAS/Frontend exchange servers (you don't have to but it makes life a lot easier).

BTW, ISA configuration is very much the same for EV8, 9 and 10, the difference is the exchange versions and how you publish them.


Chau Tran


Chau Tran's picture

If you ever need to publish EV OWA through a UAG 2010 then here's a little help:

You may or may not be aware that MS is discontinuing ISA and TMG very soon and people are already migrating to UAG because of this.

Hope this helps.


Chau Tran


Krister's picture

EV is used internal but the OWA gui is published from the ISA so you are redirected to the ISA when you enter the OWA adress and then back to the CAS/HUB. We dosent publish any buttons in OWA or Outlook to the users. All this worked before the move and upgrade to EV 10.0.2. The EV server is a new virtual 2008R2 and all athoer is working.

If you type in the NLB or the CAS adress directly you can open the archived object - after you opend the object and clicked the header in the mail. The header click wasent needed before.

If you go via the ISA published GUI then it wont work anyhow..

Thanks for your input.


Chau Tran's picture

OK...what I would do if I was in your situation:

On the EV server

1. Check the ExchangeServers.txt and make sure that all the IP addresses of the CAS servers including the CAS Load balancer IP address too.

2. Ensure that the IPv4 Address and Domain Restrictions is set to Read/Write in IIS 7.5 on the Windows 2008 R2.

3. Delete the EVAnon virtual directory

4. Re-run the OWAUser.wsf

5. Check the EVAnon virtual directory to see if it has been created correctly with all the IP addresses set to Allow.

On the CAS servers

1. Ensure that the correct EV OWA extensions are installed, reinstall if need be.

2. Check the web.config is set correctly for EV on all CAS servers.

Although the EV OWA is not used for external and you don't publish the EV buttons/toolbar, the extensions are required for internal use from what you are describing. Did you upgrade the EV OWA extensions on the CAS servers when you did your EV upgrade?


Chau Tran


Chau Tran's picture should turn on EV OWA logging on the CAS servers to see what is happening and comparing between working without ISA and not working with ISA.


Chau Tran


Krister's picture

After checking the loggs it showed that the anonymous account didnt had enough rights to the shopping directory....DONE...WORKING