Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Problem with backup of Vm's Windows 2008R2

Created: 22 Apr 2010 • Updated: 23 Oct 2010 | 3 comments
Bob-Aces's picture

Running on BE2010 on W2k3 in a Vmware ESX 3.5.0 123630 environment.

And this is the error that we are getting:

e000959a - An attempt to take a snapshot of a virtual machine failed because it was unable to quiesce an application.

For additional information regarding this error refer to link V-79-57344-38298

According to the information of the error there is no solution.

does anyone having the same problems ?

vm's that we are trying to backup are Windows 2008 R2

 

Comments 3 CommentsJump to latest comment

Colin Weaver's picture

Are you getting the application error in your event log that is discussed in the article (that is behind the link  you followed) - as if not your issue has the same V- code (known as a UMI) but is not the same problem.

Also is the remote agent for Windows installed inside you Windows 2008 R2 system - this is needed because we disable the VMware VSS writer (instaleld by the VMware tools) and add in our own version that is needed to trigger the quiesce processes - you don't need an extra remote agent license - as long as you do have the VMware agent license.

Bob-Aces's picture

Hello Colin,

Yes the agent is installed in the Windows 2008 R2 Vm's

I see one error in the event log with id 1000
And this is the discription

Faulting application beremote.exe, version 13.0.2896.0, faulting module vmwaretools.dll, version 1.0.62.0, fault address 0x01499c49.

Symanticus's picture

The following tricks working without uninstalling the VMWare tools support for VSS. Please be advised that I've tried this method on all of my failed to backup of Windows Server 2008/2003 x64 VMs

The reason why I'm doing this again is that I feel uncomfortable in removing the VSS snapshot provider support in VMWare tools:

1. Backup the following regkey: *HKLM\Software\Microsoft\EventSystem*
2. Erase the regkey HKLM\Software\Microsoft\EventSystem{26c409cc-ae86-11d1-b616-00805fc79216} an below 
3. Reboot. 
4. Verify that things are working by running

vssadmin list writers
vssadmin list providers


and then in the services.msc list of services snap ins, make sure the following services are Started Automatically:

1. COM+ System Application
2. Distributed Transaction Coordinator
3. Volume Shadow Copy
4. VMware Physical Disk Helper Service

Automatically but not started:

1. Microsoft Software Shadow Copy Provider
2. VMware Snapshot Provider 

This is the solution that i tried around myself without uninstalling the VSS Provider support in VMWare tools.

See the following KB URL: http://kb.vmware.com/selfservice/microsites/search.do?cmd=displayKC&docType=kc&externalId=1009073&sliceId=1&docTypeID=DT_KB_1_1&dialogID=38752513&stateId=0%200%2038754922

Hope this can be a helpful post for you.

/* Infrastructure Support Engineer */