Video Screencast Help

Problem with "bad packet"

Created: 05 Feb 2011
Tom Mc's picture

RECENTLY RESOLVED

PROBLEM:

I recently purchased PGP Netshare 10.1 for Windows, running it on an XP pro machine. We emailed the client our ket, they encryptes a file for a test, placed it on their FTP site. We picked it up, and when we try to decrypt the file we get a "bad packet" error message. The client is a mainframe user running z/OS, likely a command line version. They have not yet provided the version #.

I had them place the file on the FTP unencrypted, and I can encrypt/decrypt just fine. I notice that the key ID I see when I click on properties is several digits short of what their system "sees". The rightmost 8 digits match, but where ours starts with "0x", theirs shows 8 digits that we can't see.

We have tried resending the key (by email) thinking it may have been corrupted in transfer, they have re-encrypted several times, and we are getting nowhere. Also tried to Edit the file, but we get the message "PGP Desktop was unable to open (filename.pgp) The PGP Zip may be corrupt."

RESOLUTION:

It may be helpful to know what software and its version number they are using for the encryption.

What I suspect is happening with the Key ID:  PGP only shows the last eight digits of rhe Key ID, which is the Short Key ID.  I'm guessing that their software is reporting the full Key ID.  I suspect that if you look at your key's fingerprint, you will see the key ID as the last eight digits, and that the digits right before that are what they are including.

The problem might be that your FTP software is not downloading the file in the correct transfer type.  Changing your default from ASCII to Binary, or vice versa may possibly work.

COMMENTS:

Well...ain't this fun...downloaded file in ASCII mode, decrypted just fine. Looks like one side of the problem is solved.

Thank you very much, suppose I should have tried this first.