Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Problem with catalogs migration

Created: 28 Dec 2012 • Updated: 02 Jan 2013 | 6 comments
This issue has been solved. See solution.

Hello,

 

i'm facing a strange issue, i followed the Symantec procedure but unfortunately i have a problem with my catalogs.

 

I am out of space on my C disk, so i start the BEUTILITY to change the catalogs path to a new disk. Everything gones fine, then i restart my BE services. I change the configuration of BE2012 to specify the new location, and i restart the server.

Now i have to issues:

 

1) When i want to restore, BE is unable to see backup sets previous 7 days, instead of before i was able to restore for months

2) Today, after night backups run, i can see that my catalog folder on C is not empty, as if the new backups write their catalogs in the old folder.

 

Please help, because the only "bad" trick i have in mind is to create shorlink in my old folder catalog

 

 

Comments 6 CommentsJump to latest comment

Marianne's picture

You did not say which Symantec procedure you followed?
Did you also copy catalog files from previous folder to the new location?

See this TN: http://www.symantec.com/docs/TECH29603

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

nicnictout's picture

Marianne,

 

i follow this procedure yes, adapted to BE2012 of course.

Yes i copy all catalogs files to new location.

 

Now, i ran again the migration procedure to copy catalogs created this night, and when i restart the services, the restore window is blank, as if BE doesn't see anymore any catalogs...

I'm going crazy, each time i've got a problem with catalogs (import/migrate/move) it's a big headache and something always goes wrong...

nicnictout's picture

Ok i retrieve my 7 days of restore history after a reboot.

My previous catalog folder contained a catstore folder very large, i copy this folder directly in the new one, but maybe i need to copy the content of this folder directly at the root directory?

 

nicnictout's picture

Hi,

 

well, i move all files from catstrore to catalog root directory, and i can see now an history of 1 month. Far away from my previous 6 month of history.

In catalog folder i'm able to see files older than 3 months, but BE cannot see them.

Any idea of what could be the root cause of this issue?

 

Thx

 

pkh's picture

1) When you do your restore, did you expand the date range above the selection so that you can see the earlier backup sets

2) Have you tried rebuilding your catalog index with this command

C:\Program Files\Symantec\Backup Exec>catrebuildindex -r

 

SOLUTION
nicnictout's picture

Hello,

 

problème solved with pkh command. Thx a lot