Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

problem to deploy altiris agent to workstation

Created: 31 May 2010 | 8 comments

Hi,

I'm new with the altiris client management 7 solution, and I'm trying to install the CMS7 but is strange because at the Windows Servers OS  has been installed successufull, but on the workstations do not install from the Console when I select the target machine and and click to install shows this error messange "Failed to copy 'Altiris Agent install service'. I've checked the account and all the permission is fine the accout has local admin right at every machine.

Does anyone has seen this problem?

Thanks

Discussion Filed Under:

Comments 8 CommentsJump to latest comment

MLH2O's picture

Article ID: 21574 - Altiris Agent push errors:
https://kb.altiris.com/article.asp?article=21574&p=1

This KB article was created for NS 6.0, but the troubleshooting guidelines are still applicable to CMS7.

Rodrigo Benedik's picture

I've checked step by step and still not working....

Rodrigo Benedik

andykn101's picture

Is there anything in Event Viewer on the target machine or any logs in c:\windows or system32 ?

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.

Rodrigo Benedik's picture

I thinks is something with some machines, because even installing the client manually do not work and when I try to connect to the machine i can not connect on the machines with wmi.

I installed a new machine at the same subnet and with the same OS version as the machines was with problem and worked well.

Thanks

Rodrigo Benedik

KSchroeder's picture


Is the Windows firewall enabled on the machines?  I'm sure this is in the link MLH2O posted, but double-check it.  This would also impact connecting via WMI.  Can you access WMI locally on the machine?  If not, see here for instructions on repairing it.   I have had good success with the following commands (on XP SP2/3):

rundll32 wbemupgd, UpgradeRepository
cd /d %windir%\system32\wbem
for %i in (*.dll) do RegSvr32 -s %i
for %i in (*.exe) do %i /RegServer

Thanks,
Kyle
Symantec Trusted Advisor

For Forum threads, please click "Mark as Solution" if answered.
For all content, please give a thumbs up if you agree with or support the post.

mclemson's picture

I would say the answer is in there.

Mike Clemson, Senior Systems Engineer, ASC
Intuitive Technology Group -- Symantec Platinum Partner
intuitivetech.com

dcm_dude's picture

Hey Folks,

Just wanted to add my 2 cents here, I discovered that because of McAfee Anti-Virus, the Windows directory is write protected from invasive access. I tried to right click, create new random object (other than new folder) and it says access denied.

Due to the crappy nature of McAfee products (not to mention its passion for resource hogging) I rebuilt my PC since uninstalling the product is pointless because it refuses to let me do it even though I am logged in as a local admin - the agent cannot be uninstalled in Managed Mode and the Anti-Spyware Enterprise Module just says im not authorised to uninstall the component.

This has also probably mentioned a few times before, but please please please ensure, you disable simple file sharing if you are in a Workgroup (like me) since this seemlingly mild mannered tickbox truely does create havoc since it will continue to error and say that it cannot install the agent.

Turning off this feature is not Agent specific, if you use a UNC path to access a machine remotely and have simple file sharing enabled, it will not enable you to use an account other than Guest... why Microsoft even bothered to implement a pointless insecure account is beyond me. I dont know anyone, domestic or corporate that would enable that account... its simply a security risk not to mention useless.

Hope this helps fellow techies :)
DCM_DUDE :)

EugeneDisc's picture

You could also check you're AV. We found that it blocked a number of Altiris Agent files needed for the install. The most important one being system remote.

Eugene