Video Screencast Help

Problem with GRT restore of Exchange 2010 Vmware backup

Created: 30 Oct 2012 | 12 comments
kml's picture

Hi,

here is my configuration.

Master : NetBackup 7.5.0.4 on Windows 2008 R2

MSDP : NetBackup 7.5.0.4 on Windows 2008 R2

Exchange 2010 topology :

- One mailbox/database server (standalone, no DAG)

- One CAS server

- One HUB server

When i backup the mailbox/database server with a "Ms Exchange" Policy with GRT enable, everything works fine (backups and granular restores).

When i backup the mailbox/dabase server with a "Vmware" Policy with Exchange Attributes enables, backups seems to work fine (Application State Capture job + backup job) but i have an error browsing the databases on the BAR gui ==> Database system error

Is there a particular configuration to do ?

Thanks in advance

Comments 12 CommentsJump to latest comment

Lach's picture

To restore individual items from a backup that uses Granular Recovery Technology
(GRT), you must enableS ervices for Network FileSystem. When this configuration
is completed on the media server and the Exchange granular clients, you can
disable any unnecessary NFS services. More information is available on which
clients require this configuration.

REF: Symantec NetBackup™ for Microsoft ExchangeServer Administrator’s Guide for Windows Release 7.5 PAge 36

kml's picture

In fact NFS configuration is fine because i'm able to browse and restore individual items when i use a "MS Exchange" type of policy.

Error appears when i use a "Vmware" type of policy with "Enable Exchange Recovery" and "Truncate logs" check.

Thanks

Mark_Solutions's picture

When backing up via a VMWare policy type you do still select the MS Exchange policiy type for Exchange Restores

See Page 200 of the MS Exchange Admin Guide

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

kml's picture

Yes i am. I can see the first level "Microsoft Information Store" and but when i hit the first [+] to browse the database i have the "Database System Error"

Mark_Solutions's picture

So you are saying you get the error when backed up with a VMWare policy type but try and retsore using an MSExchange Policy type?

If so then increase the client connect and client read timeouts on your Master and Media Server - usually the Database System Error is caused by a timeout whilst mounting and reading the image - alternatively try using a smaller fragment size on the storage unit when you back it up (suggest 5000MB for GRT backups)

Hope this helps

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

kml's picture

Thank you Mark i'll try this and i'll give you an update.

Rami Nasser's picture

Backup Archive and Restore will report:
Database system error

This issue occur because they are multiple VMDKs on the virtual machine with the same name, and different paths

http://www.symantec.com/docs/TECH182930

it will be fixed in next maintanens release

Regards,

Mux's picture

I am also getting the same error.

  Capture.JPG

Do we know whether the issue is fixed in 7.5.0.6??

rawilde's picture

Unfortunately the "database system error" is the only real error we can produce to the GUI at this time.  To find out the reason for the error, the NBU client debugging needs to be increased to (general=2 and verbose=5)

The trace for VMware GRT browse will be in the ncflbc log under netbakup\logs directory.  This can be used in conjunction with tech support or you can also share any errors in this log and I can give my best advice.

kml's picture

Hello,

i was able to fix this becasuse VM Tools weren't up to date on the mailbox server ! After the update everything is fine.

Hope this will help.

Mux's picture

The VM Tools are up to date on the servers.. Still it is failing..

Let me see if I can find the logs...

Mux's picture

Yesterday I upgraded my master server to 7.5.0.6 and today when I checked, the error has gone away and I can see the individual mailboxes.

Master server upgrade is the only change that has happened in the environment. So I assume that did the trick.

Thanks.