Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Problem to install Symantec Streaming 7.5 Sp1 on Win 2012 x64

Created: 11 Jun 2014 | 8 comments
Anbr's picture

Hallo All

Any one then me having problem to install streaming server (STE) on a Windows 2012 x64 Server?

Install ends with NO error but no Tomcat is installed end no services.....

All logfiles is empty so I can´t see the problem.

//Anders

Operating Systems:

Comments 8 CommentsJump to latest comment

jason.f's picture

I just installed our SWS infrastructure on 2012 x64 without any issues. 2 x Server 2012 x64 Backend servers and 2 x Server 2012 Front End Servers.

Are you installing the latest version 7.5 SP1?

Jason

Anbr's picture

Yes I have downloaded the latest.....I have try two diffrent server with same problem.... 

balachandar_manimala's picture

Hello Anders,

  • What do you see in the install logs?
  • Are none of the services getting installed?
  • What are the applications installed on the server?
  • Are their other roles configured on the server? If yes, which of them?
  • Are the required ports open to allow communication?

Regards,

Bala

Anbr's picture

Hello

  • What do you see in the install logs?
    • Nothing all log catalogs are empty.
  • Are none of the services getting installed?
    • Only the Agent service.
  • What are the applications installed on the server?
    • What or where??? The server is new (clean) and the SWS install on a D patition.
  • Are their other roles configured on the server? If yes, which of them?
    • none
  • Are the required ports open to allow communication?
    • the firewall is off, and it is only local.

PS: It works fine on Win 2008 R8.

Anbr's picture

Hi all

I have now found the problem....but no solution.

The install works fine if I install on C:\ but not on D:\.

And install the solution on system disk is not a option....

I think it is the MSI and custom action and when the install start the tomcat installation.

Any one that can install on a second partition in a 2012 server?

Christyt's picture

Hi,

On a Windows 2012 server which has 2 drives namely C:\ and D:\ where C is the system drive, with default UAC settings, I have tried the following 2 ways of Installation:

1. I tried installing the 7.5 SP1 version on the D drive by creating a folder say D:\Symantec and browse this folder during the installation. In this case I was able to install and configure the server successfully. 

2. When I tried to install the server directly on D:\ drive, the installation got finished but the STE and Console services were missing. I think there are some privilege problems or UAC can be the culprit.

Can you pls try the first option and let us know?

Thanks,

Christy

Suresh_Natarajan's picture

Hi All,

First of all, installing any products on root drives are not recommended, which means in future the  modify/uninstall will creates problem in that box.

Also elevated privileges are not imposed by  runtime JVM to register services dynamically on non-system root drives.

As per SWS new installer, which installs all files/folders and register agent service, updates configuration files  with elevated privileges, and other servies are registered through java handler in order to achieve dynamic service registration while adding/removing components through Web console UI.

So, to create/register service by JVM will need enough rights on non-system Drive, and again it's depends on UAC, box architecture, platform version etc.

For SWS product, Agent service will be created by MSI installer and other services are generated dynamically on post installation stage.

The first option mentioned by Christy will definitely work out.

Thanks

Suresh

Suresh_Natarajan's picture
We can install this after creating Symantec folder under D drive adn select it via install to point install location.
 
For D:\Symantec it will  work fine, but, if we have long path with spaces on non-default drive will persists the same issue.
 
Why? means Windows 2012 OS is disabled it's shortcut path policy by default for non-system drives..
 
We need to enable it on this specific OS before installing server.
 
8.3 name creation is by default off in Windows Server 2008 R2 and Windows Server 2012. It has to be enabled and then server has to be installed. Find below the commands to check 8.3 name creation status and enable it.
 
to check : FSUTIL.EXE 8dot3name query <drive>:
 
to enable: fsutil 8dot3name set <drive>: 0
 
for example
 
to check : FSUTIL.EXE 8dot3name query D:
 
to enable: fsutil 8dot3name set D: 0
 
Please refer the link
 
We enabled this one in windows 2012 and successfully installed all the services,
 
so in the previous case JVM failed to register the service because of long path with space interpretation failed.
 
Thanks
Suresh