Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Problem with 'nbdevconfig' command

Created: 07 Jan 2011 • Updated: 10 Jan 2011 | 2 comments
This issue has been solved. See solution.

Hi All,

I am performrimng some tests for testing of OST plugin.

A test case is failed when it went to create a storage serevr on NBU using command 'nbdevconfig' and failed with EXIT STATUS : 220 , which is looking like some problem that some system call not worked or 'space not left' on device.

My question is that does continuous data traffic on NBU , degrades its perfromance ?

Because same test case passsed when  I just restarted netbackup service on NBU machine.It this is the case then it should be fixed.

Thanks in advance...

Regards,

pravar

Discussion Filed Under:

Comments 2 CommentsJump to latest comment

Murray Butler's picture

Hello,

I looked for a bit and found Stat 220 to be a database error within NBU. There could be a number of issues causing this, as the EMM database is used in a number of places. HEre is what I would suggest:

1. check to see if EMM is up and running ont he system. You can use the 'bpps -a' to do this. You can also check in the admin console in teh Activity pane, under the services tab.

2. to dig further into the issue, you would want to increase your logging level (done via the GUI, but also possible to increase for our target process via bp.conf). to do so, either adjust int eh Master server GUI for the global logging levels (set to 5), or add the line "VERBOSE=5" to your bp.conf file on the master server. Once this is done, create the bpdbm directory in the log directory and restart all services, and re-create the error.

Have a look at the log, I believe it is a legacy log, so you can find the issue by looking for "<16>" or "<32>" in teh log (this is very easy with perl or grep). Those lines will indicate an error. If the database is failing to start, that will also be near the top of the log (from the restart), you will want to check to see that the database starts successfully.

Database errors can have a number of cuases, one of the most common is either a permissions error on the files where NBU is installed, or a lack of space on the device NBU is installed on. Without sufficient space the EMM database cannot start, and iwthout EMM, NBU is not capable of doing what you need.

Please let us know what you find and if we can help furhter.

Thanks,

Murray

SOLUTION
pravar_12's picture

Thanks a Lot Murray for such a detailed trobleshooting solution.

I have an additional query.

I want to know that what happens when we stops and restarts the netbackup service using commands ./netbackup stop and ./netbackup start. Is there some changes in database of NBU when we perform these steps?

Actually , I suspect that when we stop/restart NBU services then all database entries like credentials , policies and schedules get deleted. Is it true??