Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Problem publishing Workflow

Created: 13 Dec 2012 • Updated: 13 Dec 2012 | 7 comments
This issue has been solved. See solution.

New day, new issue...

Trying to publish my workflow after successful tests in debugging mode, and when stepping through the wizard I get the following error:

The ServiceDesk AppPool and Symantec Workflow Server service both run as a service account that has explicit admin rights on the box (and is a sysadmin of the ProcessManager database, if that's even required for publishing), and the user account I was logged in with to edit/publish the workflow also has explicit admin rights on the box.  I'm publishing locally. 

Any help you all can provide would be most welcome.  Thanks in advance!

Comments 7 CommentsJump to latest comment

reecardo's picture

Check your Server Extension settings on the "receiving" machine. If there is a "Allow Remote Connections" checkbox (3rd down from the top under General), it needs to be turned on... on the remote server receiving the workflow.

SOLUTION
etk1131's picture

It was unchecked for some reason.  All set now.  Thanks again for your help Reecardo! 

Nick at Sparrow's picture

Here is a screenshot of the setting for anyone that needs it.

DanGordon's picture

This setting appears to have been introduced in WF 7.5 - tripped us up a bit when performing the upgrades. It wasn't there in 7.1 SP2!

reecardo's picture

Just so... we added this setting as a security measure. We will definitely have this documented for 7.5.

CNWilliams's picture

Hi,

This security measure has been documented in the Symantec ServiceDesk 7.5 Release Notes, along with a related KB Article.

ServiceDesk 7.5 Release Notes: http://www.symantec.com/docs/DOC5720

ServiceDesk/Workflow General Security Best Practices: http://www.symantec.com/docs/DOC6160

Component

Issue

Article link

Improved security controls on the Workflow Server

Symantec has improved security controls on the Workflow Server. The improved security can potentially block the ability to deploy from a local Workflow Designer to a remote Workflow Server. If you cannot  deploy to a remote Workflow Server, change the following setting on the remote Workflow Server before attempting to deploy.

To allow remote connections:

  • On the Workflow Server, right-click on the Task Tray Tool and click Settings.
  • In the Workflow Server section next to Workflow Server Configuration, click the ellipsis.
  • In the General section, check Allow Remote Connections.

Please note that the Symantec security best practice is to revert this setting after you are finished deploying. For more information on Symantec security best practices, see the article ServiceDesk/Workflow General Security Best Practices.

www.symantec.com/docs/DOC6160

Kindest Regards,

CNWilliams

CNWilliams

toomas's picture

Just to make it clear, the change itself has been introduced in Workflow/ServiceDesk 7.5.

However, the same change is also done in the Workflow 7.1 SP3 Rollup (or possibly a late version of Workflow 7.1 SP2 Rollup) which you may have gotten from Support (or otherwise from Symantec people).