Video Screencast Help

Problem with really old EV installation...

Created: 21 Jan 2013 • Updated: 03 Apr 2013 | 18 comments
This issue has been solved. See solution.

Hello, Im new here so please bear with me :) 

We have a really really old version of enterprise vault (Version 6) installed as an archive for some of our old users. 

No one knows anything about the system as it was setup years ago and the people involved have long since left.

We are having a problme retreving all emails from the vault, the user gets Failed to get the document from the Storage Service.

at the same time the following is logged in the event log on the server.

 

Event Type: Warning
Event Source: Enterprise Vault 
Event Category: Web Application (WP) 
Event ID: 6287
Date: 21/01/2013
Time: 7:51:09 PM
User: N/A
Computer: SGENTV01
Description:
Unable to fetch item from 
Reason: The server threw an exception.  0x80010105 
Saveset Id: 644000000000000~200607270544360000~1~006B60EEEA9B472F8517AFDE8D8A864 
Archive Name:***********************
Archive Folder Path: Sent Items 
Reference: [GOAFS] 
 
For more information, see Help and Support Center at http://evevent.veritas.com/rosetta/showevent.asp
I dont really know where to start, but ive tried various things like changing the service password, reinstalling outlook on the server etc. 
any help would be appreciated!! 
 
Regards
 
Dave J

Comments 18 CommentsJump to latest comment

TonySterling's picture

Is there any other events after the 6287?

It sounds like the archived items can't be recalled from your storage device.

JesusWept3's picture

You may want to try a reinstallation of the binaries as well

therealdj's picture

Hello, 

Thanks for replying, thats the only error im afraid, Ive also tried to do a PST export and get this message..

 

Event Type: Error
Event Source: Enterprise Vault 
Event Category: Migrator Server 
Event ID: 6794
Date: 21/01/2013
Time: 6:56:18 PM
User: N/A
Computer: SGENTV01
Description:
Error restoring Saveset during export operation. 
 
Job Id: Exp3_20130121185152 
Vault Name: ********************
Vault Id: 11EAF1BA2CDC3304085F38481E3C017551110000SGENTVAULT.behringer.corp.intra 
Saveset Id: 576000000000000~200607011151250000~0~E685A3C714F2437EA6AAA3638A507F4 
Reference: CRF/CF/1 
 
For more information, see Help and Support Center at http://evevent.veritas.com/rosetta/showevent.asp
Data:
0000: 3c 30 78 38 30 30 34 30   <0x80040
0008: 31 30 33 3e               103>    
 
As far as im aware all of the data is stored on the e:\ drive on the server. Is there any way to know which file the service is trying to retreave so I can check if its present?
 
Regards
 
Dave J
TonySterling's picture

Do a dtrace of the storage service and recreate the error.  You can then zip that up and attach it to your post here.

In case you have never run a dtrace heres how:

Command Line - 6.0 and higher

1.  Log on as the Vault Service Account.

2.  Open a Command Prompt window.

3.  Change to the Enterprise Vault program folder (normally C:Program FilesEnterprise Vault).

4.  Type dtrace, and then press Enter.

5.  At the Dtrace prompt (DT>) type V or View.

6.  Record the Id number beside the service or services that are failing.

7. Use the following command to set Dtrace for logging against a specific service.
 

set servicename_or_ID level
For example, if running a Dtrace on the Admin Service and the ID is 1, then the syntax would be:
 
set 1 v
8. Repeat for as many separate processes as required.

9. Use the following command to specify the log file name:
 

log tracelog.log

Note: A path can also be entered for the location of the file. If only a file name is provided, the location of the trace file will be the directory from which Dtrace has been run.

10. Minimize the command prompt window, but do not close.

11. Reproduce the issue or wait until the issue reoccurs

12. Maximize the window, at the DT prompt, type quit. Type y to disable all tracing.

therealdj's picture

Ive attached the trace log as requested.

Thanks for your help! 

Regards

Dave J

AttachmentSize
tracelog.zip 3.53 KB
JesusWept3's picture

Actually looking at that, i think i've seen that before with server side conversion and it being downloaded as a message instead of the DVS being delivered to the end user, but i cant for the life of me remember the policy setting

therealdj's picture

Thanks for the replys, I cant get on the system at the mo to do the reg export, but it is all retrievals and from what I could see the files are there on the drive. 

Thanks again,

Dave J

JesusWept3's picture

The files definitely exist, you can see it says it right at the top of the dtrace

How are the files being opened btw? through Outlook or through Search or Archive Explorer?
if its outlook, can you check the Archiving Policies under Desktop, there is a download type policy, something like Message File or DVS file

Message file means it converts it on the server
DVS File means it downloads it to the desktop as a DVS and the outlook addin converts it to an msg

But again, i can't remember what the name of it is

 

JesusWept3's picture

Actually, scratch that, it looks like you have this issue

http://www.symantec.com/business/support/index?page=content&id=TECH51020

Can you get a dtrace of RetrievalTask to confirm?
There is no fix unfortunately

therealdj's picture

Hello,

Ill get a trace over asap, ive been trying to get a reg export from the server. Strangly I cant find the reg keys in the obvious places.. HKLM\software\etc\

Also do you have any information about what happenes during retrevial? Is the archive manager mailbox required as part of this process? the system is really old, and ive got a feeling the EV mailbox is not online.

Thanks again!

Dave J

JesusWept3's picture

To restore items and archive items the EV system mailbox would need to exist and be accessible, otherwise the archiving task would be In a failed state

However just for opening items through outlook or the webapp, it goes through storage and does not interact with exchange at all

So my suggestion is to make sure the mailbox is online, visible in the gal, accessible by the evadmin account and on the correct exchange server

Also try a reinstallation of the EV binaries and then reboot.

But unfortunately I really do think you have the bug mentioned above in the technote, they are almost exactly identical

therealdj's picture

I have attached the dtrace for the retrevial task, im not sure if it looks like that bug.

Ive got a copy of the binaries, am I likely to lose anything by just installing over the top?

Thanks again for your help! 

Dave J

AttachmentSize
tracelog2.txt 2.5 KB
JesusWept3's picture

Hmmm ok,
so here's a question!

On the EV Server, go to Start -> Run and paste the following, then hit OK

E:\Enterprise Vault Stores\SGENTVAULTSTORE01 2006Q3\2007\10\19\15\380000000000000~200710191534450000~0.DVS

Does the item open in Outlook?

And reinstalling the binaries will not lose anything, all the reg keys will stay intact, all the configuration data in the database will remain untouched, and the vault store partitions and indexes will be left alone, what it will do though is refresh all the dcom packages, re-register all the DLL files and server processes etc

therealdj's picture

Ill give the reinstall a try, If i try to open that item on the server I get the following message..

Could not show this item
Please try again; if it still failes, contat your Enterprise Vault administrator.

Best Regards

Dave J

JesusWept3's picture

OK so that is not good, if it can't open it straight from the DVS then it will fail to retrieve in almost all EV2007 installations and below... its a shame that EV6 is out of support, otherwise you could have had them do an integrity check on the DVS for you

I would offer to do it for you but that would involve sending me the DVS file which is a copy of the email, and contains things like email addresses and what not

But unfortunately I don't think this is an EV environment or installation problem, i think this is a data integrity issue with the DVS files themselves and that they are physicaly corrupt

SOLUTION
therealdj's picture

Oh its not looking good then! :( 

It is strange though as it seems to be all emails within the archive though. I could look try and look though and see if i can find a none important looking email (from the subject) if you are willing to have a look at it? 

Thanks again! 

Dave J

JesusWept3's picture

yeah you could use search.asp
and search for something that is obviously spam, try and open the item and then you'll have an event throw in the event logs which will show the direct path to the item, i've no problems looking at it