Video Screencast Help

Problem setting up replicated data set

Created: 25 Oct 2012 • Updated: 04 Dec 2012 | 2 comments
This issue has been solved. See solution.

Setting up VR replicated data set for the first time and received the message

"The selected Dynamic Disk Group does not contain any valid volumes which can be used for replication.
Note that Storage Foundation RAID5 volumes and volumes having Dirty Region Log are not supported."

I have an attached disk array that is configured Raid 5 but the volume is presented to VEA as a blank dive with no File format, so I am not sure if that is the problem. Also what is a Dirty Region log?

UPDATE: I see what the DRL is now and I do have that. If appears to have been create by veritas though when I first setup the diskgroup. How do I get rid of it?

ANSWER: I got it, what I had to do was blow away my mirrored Volume in the Disk group. When I create my volume I normally will select mirrored and let VEA take care of it but that is what creates the DRL file. I did the same thing for my Volume creation but didnt select Mirror. After the volume was created I right clicked and selected add mirror. No DRL, problem solved.

Discussion Filed Under:

Comments 2 CommentsJump to latest comment

Wally_Heim's picture

Hi mhab11,

RAID 5 on the Array side should not be a problem.  Dirty Region log is used in a mirror volume and you have not volume created yet.  So I don't think these are your actual problem.

VR stands for Volume Replicator.  I think you are getting the message because you do not have a volume created and formated yet. 

Create a volume, format it and then try to setup replication again.  Keep in mind that you will need to setup a second volume that is not formated for use as the Replication Log volume.

Thank you,