Video Screencast Help

Problem using nbcatsync

Created: 15 Aug 2013 • Updated: 02 Oct 2013 | 5 comments
valor88's picture
This issue has been solved. See solution.

Hi all,

I'm having trouble running the nbcatsync command. Currently we have a production and DR site, both with their own netbackup masters. All backups carried out on either of them is duplicated via OST and SLP to a storage unit which points to the other site. This is the same for catalog backups.

 

However, when trying to run the nbcatsync -sync_dr_file command on the DR site to fix the media IDs in order to do a catalog image only recovery, we get the following message

[root@gyl-massvr01-bkp tmp]# nbcatsync -sync_dr_file ./tlp_catalog_backup_1376577927_FULL -dryrun

nbcatsync: No changes will be performed (-dryrun specified)
 
All media resources were located
   Primary Disk Media Id      Current Disk Media Id
   =====================      =====================
 
nbcatsync: No copies of Catalog Image (tlp-massvr01-bkp_1376577927) found
[root@gyl-massvr01-bkp tmp]#
 
 
On the other hand, when trying to run the nbcatsync -sync_dr_file on the production site, it returns an error code 114, no matter which DR file we use, even if the DR file is from its own catalog backup
 
[root@tlp-massvr01-bkp tmp]# nbcatsync -sync_dr_file ./gyl_catalog_backup_1376577988_FULL -dryrun
nbcatsync: No changes will be performed (-dryrun specified)
 
All media resources were located
nbcatsync: failure occurred while locating image: gyl-massvr01-bkp_1376577988
nbcatsync: Failure occurred finding Catalog Image.
nbcatsync: EXIT STATUS 114
nbcatsync: unimplemented error code 114 (114)
 
This issue has been bugging us for months. Does anyone  have any idea why is the happening?

 

Operating Systems:

Comments 5 CommentsJump to latest comment

L. Voller's picture

Hi Valor88,

There are a few different things that can cause a 114, so to try and narrow it down a bit could you tell me the following:

1) Which version of Netbackup are you running?

2) Approximately how long is it after running the command that you get the 114 error?

 

valor88's picture

We are running on nbu 7.1.0.3

The error returns almost immediately after i run the command

phil_scarfo's picture

Be advised that there should not be a space between the -sync_dr_file and the location of the dr file.
Also use the complete file path whenever possible. (that's just me saying that..keeps me from referring to locations that don't exist depending on where I'm at in the file system)
Example below.

# nbcatsync -sync_dr_file/dr_info/tlp_catalog_backup_1376577927_FULL -dryrun

valor88's picture

Hi, thanks for the replies.

The error 114 that we encountered somehow vanished when we rebooted the server.

As for the No copies of Catalog Image (tlp-massvr01-bkp_1376577927) found, we found out that we did not create the same disk pools for both sites, thus the command could not find the diskpool containing the catalog images.

Thanks all!.

SOLUTION
valor88's picture

Oh, and the format we typed to use nbcatsync was

 

nbcatsync -sync_dr_file ./tlp_catalog_backup_1376577927_FULL -dryrun

 

WITH spaces in between, and the full path for the DR file. I remember seeing it somewhere saying that no spaces inbetween, but the example given on the page itself contained a space. Anyhow, the way that worked for us was to have a space seperating the -sync_dr_file and the dr file location.