Video Screencast Help

Problem to virtualize a msu file

Created: 12 Jul 2011 | 5 comments
gsalerno's picture

Hi all,

I would like to capture a msu file in a virtual layer but when I capture (application and global capture) nothing is installed.

Could someone help me or tell me if that is possible or not.

If you would like to test the installation here is the link of the msu package:http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=7887

I'm in x64 windows 7 enterprise

Thank you very much for your help

Comments 5 CommentsJump to latest comment

Bob Wooding's picture

Did you find anything out?

Principal Consultant
Bob Wooding

gsalerno's picture

I have found nothing about virtualisation of an msu

Salerno Giuseppe
System Engineer
Bechtle Suisse Romande

AngelD's picture

It could be the same issue "we" had with MSI installations due to the Windows Installer services that had to be handled "special".

Have you tried using the command:
wusa.exe Windows6.1-KB958830-x64-RefreshPkg.msu

It could be that the files are "leaked" to the (guessing windows update) service and therefore does not catch the files.

gsalerno's picture

Hi,

Yes, I've tried to do it with wusa.exe but it have captured nothing.

Have you ever test to catch the installation of an msu files?

Salerno Giuseppe
System Engineer
Bechtle Suisse Romande

balachandar_manimala's picture

Hello Giuseppe,

I tried creating a standalone layer for Remote Server Administration Tools for Windows 7 SP1 on clean Windows 7 x86 Enterprise machine.
 
The command line mode (Single Program Capture-Browse and select cmd.exe and then run the file) and Global Capture seems to work fine.
 
Global captured is recommended as the application needs KB958830 to be installed prior to capturing the Remote Server Administration Tools through Control Panel.
 
- Standalone SWV layer creation through global capture mode and through command line works fine
- Package creation in WVC (command line mode) works fine and package gets created
 
Additional Notes:
=============
I had to extract the *.MSU file to a location (please follow the link below) and then use WVC to create package. Upon streaming it shows up under Start Menu->Administrative Tools.
  
http://support.microsoft.com/kb/262841 
 
I used Wusa.exe. You can also use many converters available on internet as well. Or you can also run the command expand as mentioned in the below link:
http://www.windowswiki.info/2009/02/19/how-to-extract-msumspmsiexe-files-on-the-command-line/ 
 
HTH,
Regards,
Bala
 
PS: Please mark as resolved if yes :)