Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Problemas para configurar el Backup de un Oracle RAC

Created: 02 Nov 2011 • Updated: 03 Nov 2011 | 7 comments
This issue has been solved. See solution.

Buenas,

 

Tengo un Backup Exec 2010 R2 instalado en un Windows Server 2008 Standard y 2 servidores RedHat Enterprise Linux 5.2 con un Oracle RAC 10g instalado.

He instalado el agente RALUS en ambos servidores linux y configurado el mismo con los datos de las instancias de la BBDD.

En el Backup Exec me aparecen las instancias al crear un trabajo de Backup con sus correspondientes ficheros y con las credenciales creadas (usuario de linux perteneciente al grupo Beoper y usuario SYS de las BBDD) puedo acceder y seleccionarlos sin problema.

Ahora bien, cuando intento acced un test de credenciales del trabajo me falla con un error "Failed" en la cuenta de sistema y un "Incorrect Function" en la de SYS. Por supuesto al intentar realizar el Backup falla tambien y da un error "e0000340 - The Database script returned an error."

Le he dado vueltas y vueltas a la configuracion del manual del BExec y a los documentos de la web de Symantec sin solucion hasta ahora.

Alguna pista de por donde puede venir el problema?

 

Gracias,

Xuacu

Comments 7 CommentsJump to latest comment

AmolB's picture

Refer to below links. Also paste the error message from the Rman log which is displayed in the Backup

Job Log.

 

http://www.symantec.com/docs/TECH49608

http://www.symantec.com/docs/TECH54288



 

ixuacu's picture

Hi Amol,

The links are for the Windows Agent configuration, nevertheless i have added the Servers to the list as described on the BeAdmin document: (RAC-<dbname>-<dbid>) one entry for each instance, and added the Beoper user and Database SYS user to the BExec credentials.

I have configured the Agent not to use RMAN.

I´ve attached the error log from Backup Exec, i´ve nothing at all on the Oracle side.

 

Cheers,

Xuacu

error log backup exec.jpg
AmolB's picture

It seens you are running a test job, could you please run the actual job and post back the 

error message from the RMAN log

newsolutionBE's picture

Hi

 

This will help you too debug please click on link & you can check the log or post them here

 

http://www.symantec.com/docs/TECH67247

 

Thanks

Thanks & Regards

If this response answers your query, please mark it as a solution.

SOLUTION
Tmy_70's picture

Puedes validar que el usuario que va a realizar el backup debe ser administrador de dominio, asi como administrador de oracle y el mismo debe levantar los servicios valida y nos comentas.

If this post has helped you, please vote or mark as solution. MBA. TC Venezuela Consultor Power

ixuacu's picture

After checking the logs from newsolutionBE i´ve discovered a misconfiguracion on the server 2 trying to use RMAN.

Now it works!!!

 

Thanks a million guys!!