Video Screencast Help

Problems with BUE and VMWare Backups

Created: 22 Jul 2014 • Updated: 24 Jul 2014 | 10 comments
This issue has been solved. See solution.

I have been told that I will have a few project shortly to upgrade some of our clients to BUE2014. Awesome I say, time to play with it in my lab.
I download and install the trial, set it up no issues. Go to back up DC01 on ESX01 via vCenter. Fine, works great. Add DC02 on ESX02 to the same job, also via same vCenter. Can't quiesce the snapshot, backup fails.

First step was to remove and reinstall agent, no joy. Next I removed the VM from inventory, and even removed the ESX host from vCenter, still won't backup. Out of desperation, I re-initialised the DB on my vCenter appliance. Re added everything, and nope, still no love.

I removed everything from that ESX box, and re installed ESX. Ran up a brand new VM (Server 2008r2) installed VMWare tools and BUE Agent. Same error.
When I snapshot the machine directly from vSphere, while logged on as the service account used for the backups, no problems. Can create a quiesced snapshot and remove it without an issue.

Now, is this some kind of limitation with the Trial period, or is there some other issue going on?

I haven't tried backing up directly from the ESX host as of yet, but that kind of defeats the purpose

Operating Systems:

Comments 10 CommentsJump to latest comment

pkh's picture

Are the vcenter host and the VM hosts on thy he same software level?

VJware's picture

Would you post the complete job log. Additionally, are GRT options enabled for the DC02 backup job ? If yes, does disabling them make a difference ?

Which snapshot providers are installed on the DC02 VM ?

Firman's picture

A symaney employee who frequests reddit pointed me at this tech article (http://www.symantec.com/docs/TECH205946). Which directed me to ensure that the VMWare VSS stuff wasnt installed. Which I have done.

I don't think GRT is the option, as when I migrate a VM from the effected ESX server, to another one, the backup works fine. The problem only seems to be effecting VM's on that specific ESX host.

I have also tried backing up the VM from that specific host directly and I have the same problem.

VJware's picture

Is this specific host licensed for VADP ?

Firman's picture

Both hosts have "vSphere 5 Enterprise Plus" with the following features;

    Unlimited virtual SMP

    vCenter agent for VMware host
    Reliable Memory
    vShield Endpoint
    vSphere Replication
    SR-IOV
    vSphere API
    Storage APIs
    VMsafe
    vSphere HA
    Hot-Pluggable virtual HW
    vSphere vMotion
    vSphere FT
    vSphere Data Protection
    vShield Zones
    vSphere DRS
    vSphere Storage vMotion
    MPIO / Third-Party Multi-Pathing
    vSphere Distributed Switch
    vSphere Host Profiles
    Remote virtual Serial Port Concentrator
    vSphere Storage I/O Control
    Direct Path vMotion
    vSphere Storage APIs for Array Integration
    Shared Smart Card Reader
    vSphere Storage DRS
    vSphere Profile-Driven Storage
    vSphere vMotion Metro
    vSphere Auto Deploy
    vSphere View Accelerator
    vSphere App HA
    vSphere Flash Read Cache

VJware's picture

I don't see vStorage API (VADP) being licensed. This is a bit strange as the other host seems to work fine. Have you enabled debugging or better still, contacted Support on a formal support case ?

Firman's picture

Storage API and vSphere Data Protection are both in there.

I didnt think it was actually a vmware problem. I can log into vSphere with the service account, create and quiesce a snap shot. Both ESX hosts have the same level of licensing applied.

The only difference between the hosts is the hardware that they sit on.

Also, I never had these issues with BUE2012. However, I was using a NFRS license on 2012, where as I am currently using a Trial of 2014.

VJware's picture

Have you activated the Agent for VMware & Hyper-V option in this trial edition of BE 2014 ?

And, Storage API and vSphere Data Protection are actually not the same as vStorage API.

Lastly, without debugging, it would be difficult to narrow down the cause of this generic error.

Firman's picture

Yes the agent for VMWare and Hyper V is enabled.

Looks like re-applying the licensing has done it. I still dont see vStorage API in my list of features, but I'm not too fussed.

Thanks for your help :)

 

SOLUTION