Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Problems installing on Linux server

Created: 04 Jan 2010 • Updated: 11 Sep 2013 | 9 comments
This issue has been solved. See solution.

Good afternoon. I have been trying to install Symantec Backup Exec revision 10.1.5629 - Remote Agent for Linux and UNIX Servers (RALUS).
I have gotten through most of the installation but have hit a roadblock.
When I attempted to start Backup Exec I received the following message

 

[root@lion2 linux]# /opt/VRTSralus/bin/VTRSralus.init

 
-bash: /opt/VRTSralus/bin/VTRSralus.init: No such file or directory

So I looked at my installation information and noticed this line:

 
    Cannot install VRTSralus ........................... ERROR 2 of 2 steps
error: Failed dependencies:
        libstdc++-libc6.2-2.so.3 is needed by VRTSralus-10.00.5629-0.i386

   After looking through this support document http://seer.entsupport.symantec.com/docs/284009.htm  I tried to download all of the packages that this installation needs.
  
 [root@lion2 ~]# rpm -ivf compat-libstdc++-devel-7.3-2.96.128.i386.rpm
warning: compat-libstdc++-devel-7.3-2.96.128.i386.rpm: Header V3 DSA signature: NOKEY, key ID a7048f8d
error: Failed dependencies:
        compat-libstdc++ = 7.3-2.96.128 is needed by compat-libstdc++-devel-7.3-2.96.128.i386
[root@lion2 ~]# rpm -ivf compat-libstdc++-7.3-2.96.128.i386.rpm
warning: compat-libstdc++-7.3-2.96.128.i386.rpm: Header V3 DSA signature: NOKEY, key ID a7048f8d
Preparing packages for installation...
compat-libstdc++-7.3-2.96.128
[root@lion2 ~]# rpm -ivf compat-libstdc++-devel-7.3-2.96.128.i386.rpm
warning: compat-libstdc++-devel-7.3-2.96.128.i386.rpm: Header V3 DSA signature: NOKEY, key ID a7048f8d
Preparing packages for installation...
compat-libstdc++-devel-7.3-2.96.128
 [root@lion2 ~]# rpm -ivf compat-gcc-c++-7.3-2.96.128.i386.rpm
warning: compat-gcc-c++-7.3-2.96.128.i386.rpm: Header V3 DSA signature: NOKEY, key ID 73307de6
error: Failed dependencies:
        compat-gcc = 7.3-2.96.128 is needed by compat-gcc-c++-7.3-2.96.128.i386
[root@lion2 ~]# rpm -ivf compat-gcc-7.3-2.96.128.i386.rpm
warning: compat-gcc-7.3-2.96.128.i386.rpm: Header V3 DSA signature: NOKEY, key ID a7048f8d
error: Failed dependencies:
        glibc-devel is needed by compat-gcc-7.3-2.96.128.i386
[root@lion2 ~]# rpm -ivf glibc-devel.rpm
warning: glibc-devel.rpm: Header V3 RSA/SHA256 signature: NOKEY, key ID 307e3d54
error: Failed dependencies:
        glibc = 2.8.90 is needed by glibc-devel-2.8.90-16.2.s390
        linux-kernel-headers is needed by glibc-devel-2.8.90-16.2.s390
        rpmlib(PayloadIsLzma) <= 4.4.2-1 is needed by glibc-devel-2.8.90-16.2.s390
[root@lion2 ~]# 


Unfortunately it seems I’ve made down to the kernel. Is there an easier way to do this? Should I just run up2date and test it again?

 
Thanks.

Comments 9 CommentsJump to latest comment

hemant chugh's picture

The problem seems to be while installation  of linux  development  libraries were not selected so while  starting the BE remote agent  it failed to start the service  because its not able to resolve  dependencies and asking to  install the packages.

Hemant Chugh
=====================================
Technical Support Engineer,
Microsoft Certified System Administrator 2k3,
Symantec Technical Specialist,
Veritas Certified Professional,
CEH – V6 Certified Ethical Hacker
========================

MrRogers's picture

Thank you for the reply.

I'm not too familiar with Linux (yet). Is there a way that i can select the development libraries when installing or work around this some other way?

Thanks again.

Dev T's picture

Hello,

download the patch from:
 http://rpm.pbone.net/index.php3/stat/4/idpl/1548897/com/compat-gcc-c++-7.3-2.96.128.i386.rpm.html

Install the patch:
[root@lion2 ~]# rpm -i --force compat-libstdc++-7.3-2.96.128.i386.rpm
(do not put a space between the dashes)

Hope this helps...

Its a best practice to have a "Support Contract" with Symantec...
 

BEsymc's picture

What is the version of linux? It does not look like being compatible with 10d RALUS. Consult Software Compatibility list for the same, before trying to make much changes with your Linux Server. Following is the software compatibility list:

http://seer.entsupport.symantec.com/docs/278254.htm

Please mark it a solution, if this is useful.
Thanks

MrRogers's picture

Thanks Dev T, but I have already tried to use that rpm package. It was dependant on other packages which were dependant on other packages, et cetera.

Looks like BEsymc is correct.
The output after running cat /etc/*release* was CentOS 5.2 (Final). I didn't find this distribution listed in the page you provided me.

I guess I will have to look into a older version of Symantec Backup Exec, since updating the kernel (new distro) would be a big undertaking.

Is there a way for me to find which version I would be able to use?

Thanks for your help everyone.

BEsymc's picture

The distributions listed in the software compatiblity list, i mentioned above will tell you which distributions will work with Backup Exec. CentOS is not supported distribution for Backup Exec.

Please mark it a solution, if this is useful.
Thanks

evg's picture

I just experienced the same problems on a new and fully patched Fedora 12 system and since we do not want non-fedora signed packages on this system I searched for a replacement like this:

#> yum search compat-libstdc++
============ Matched: compat-libstdc++ =======================
compat-libstdc++-296.i686 : Compatibility 2.96-RH standard C++ libraries
compat-libstdc++-33.i686 : Compatibility standard C++ libraries

Our Fedora 10 system with RALUS working has the 296 version so that's what I picked:
yum install compat-libstdc++-296

Then BEFORE installing RALUS fix the install script which calls "usermod -G $groupname root"  which on Fedora (and probably RHEL, CentOS systems it removes all supplimentary groups for the root user!!! (check /var/log/secure for proof). Instead you should fix this via:
vim ralus/scripts/install/RALUS.pm   and add an "a" to the -aG in the line below (read usermod for details specific to your distribution):

Red Hat Linux 5 Hardening Tips
SNAC
Red Hat, Linux 5
11.9999

Normal
0

false
false
false

MicrosoftInternetExplorer4

/* Style Definitions */
table.MsoNormalTable
{mso-style-name:"Table Normal";
mso-tstyle-rowband-size:0;
mso-tstyle-colband-size:0;
mso-style-noshow:yes;
mso-style-parent:"";
mso-padding-alt:0cm 5.4pt 0cm 5.4pt;
mso-para-margin:0cm;
mso-para-margin-bottom:.0001pt;
mso-pagination:widow-orphan;
font-size:10.0pt;
font-family:"Times New Roman";
mso-ansi-language:#0400;
mso-fareast-language:#0400;
mso-bidi-language:#0400;}

“$command = $usermod . " -aG $groupname root";

IF YOU ALREADY TRIED INSTALLING RALUS then review /var/log/secure or just "grep root /etc/group" to see if the root groups were removed, then add them back (for Fedora 12: bin,daemon,sys,adm,disk,wheel).

Test and save for future use on other systems but be aware is just free advice that worked for me and may effect your warrany/support.

The remaining install worked for me but you should check your install log anyway.
Good luck

SOLUTION
evg's picture

The previous post mysteriously added all the mistaken lines from:
Red Hat Linux 5 Hardening Tips
....
to
mso-bidi-language:#0400;}

Those lines should be deleted.

evg's picture

If you backup filenames with non-English characters then ensure LATIN-1 is in:

Software\VERITAS\Backup Exec\Engine\RALUS\Encoder=LATIN-1

in this file: /etc/VRTSralus/ralus.cfg