Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Problems with reduction of privileges in a VCS 5.1 with SQL Server 2005

Created: 16 May 2013 • Updated: 20 May 2013 | 3 comments
This issue has been solved. See solution.

Hi,

We have a VCS 5.1 for windows 2003 R2 Enterprise edition x64 with 3 nodes (one local cluster with 2 nodes and alternate site with one node for BRP)

Originally we created the vcshelper for cluster control and a domain user account for SQL Server service.

For these accounts the installer requested domain administrator privileges so we granted.

 

Now for security management reasons and allignment with HQ we need to reduce privileges on these 2 accounts so we were reffered to document:

http://www.symantec.com/business/support/index?page=content&id=TECH31331

 

We did this but whenever we reduce privileges on the accounts the sql server does not start. I present the sequence of events below.

Steps:

1.We removed administrator privilege from vcshelper and domain user account

2. We changed both accounts for Veritas and SQL server. We restarted service in one machine and worked fine

3.Then we failed over to the other node and the cluster was fine but SQL could not start sending error:

 

Failed allocate pages: FAIL_PAGE_ALLOCATION 1

Error: 17311, Severity: 16, State: 1. (Params:). The error is printed in terse mode because there was error during formatting. Tracing, ETW, notifications etc are skipped.

 

4.I retried removing the account and using Local system account but got same message

5. We put back privileges to VCShelper  and domain user account

6. And with this I made a failover cycle between the two nodes and worked fine. (A to B and B to A)

 

PLEASE ADVISE ON WHAT TO DO TO ALLOW SQL SERVER TO START

 PS: We haven tried the next text of failover to alternate site due we have this problem in local cluster

Thanks in advance

Operating Systems:

Comments 3 CommentsJump to latest comment

Kedar Sane's picture

Hi Gil,

You have mentioned in step 2 above –

“2. We changed both accounts for Veritas and SQL server. We restarted service in one machine and worked fine”

Could we check if the service account used for the SQL server on first machine (machine where everything worked fine) has privileges on the SQL server on the other machine?

To test this, we can assign the SQL server on the second machine the same service account as used on first machine and try to start the SQL server outside VCS control. If that works, then VCS should also be able to bring the SQL service online.

Gil Tapia's picture

Hi,

Thanks for your help. The problem went away when we restarted all machines after reducing privileges.

Regards

SOLUTION