Video Screencast Help

Problems with restoring a mailbox BE/EXCH 2010

Created: 06 Nov 2013 • Updated: 06 Nov 2013 | 9 comments

Hey All,

Trying to restore a single mailbox using redirection, and not having much luck.

The server "companydc" has AD, Exchange 2010 and Backup Exec 2012 installed.

Getting the following error:

e0000382 - Backup Exec attempted to restore an Exchange database according to the job settings. The Exchange server was not found.
For additional information regarding this error refer to link V-79-57344-898

Have done the following:

  • Manually add the server FQDN and IP to the hosts file to eliminate DNS issues.
  • Restart backup exec services.
  • Checked that the mailbox is created, not hidden from GAL
  • Added permissions to the mailbox to companyadmin
  • Changed all temp locations between E: (Where the db is stored), C: and Z: (An external drive with heaps of space
  • Check BE services can access the temp locations
  • Scratched head extensively

Job settings are as follows:

Media Location
Media or Resource    Media Location
Tuesday1    HP 0001

Resources    Resource Credentials
COMPANYDC    companyadmin
Mailbox Database    

File Redirection
Redirect file sets: Yes
Restore to drive:\\COMPANYDC\C:
Server logon account:companyadmin
Restore to path:TEMP
Path logon account:
Create a Microsoft Virtual Hard Disk for redirected files (Windows Server 2008 R2 or later): No
Microsoft Exchange Redirection
Redirect Exchange sets: Yes
Restore to server or Database Availability Group:\\companydc.corportation.local
Server logon account:companyadmin

Redirect using Volume Shadow Copy Service (VSS) snapshot provider: No

Redirect mailbox sets: Yes
Restore to mailbox:UserRestore
Mailbox logon account:companyadmin

Path on an NTFS volume that is local to the media server for temporary storage of restore data (Microsoft Hyper-V, Exchange, SharePoint, and Active Directory, and VMware restore jobs only): C:\TEMP
Microsoft Exchange
Automatically recreate user accounts and mailboxes: No
When restoring individual mail messages and folders, restore over existing messages and folders: No

Exchange 2000 and later
Log recovery options when restoring the Information Store:     Restore all transaction logs; do not delete existing transaction logs (no loss restore)
Path on Exchange Server for temporary storage of log and patch files:     C:\TEMP

Dismount database before restore: No
Commit after restore completes: Yes
Mount database after restore: Yes

Operating Systems:

Comments 9 CommentsJump to latest comment

pkh's picture

When you take the backup, did you turn off AOF? AOF may cause problems with redirection

CraigV's picture


So the C:\ drive on the media server has enough disk space to handle the temporary staging of the entire Information Store to disk?

Have you tried to manually stage to disk before doing the restore? Check the link below for more information:


Alternative ways to access Backup Exec Technical Support:

turtlefence's picture

Hi Craig,

Thanks for that, I am still getting the same error message but now have the backup on disk :)

Jaydeep S's picture

Are you trying to restore the mailbox as a .pst file on \COMPANYDC\C: If so, then Microsoft Outlook 2003, 2007, or 2010 (32-bit only) must be installed on the destination server when you restore to a .PST. Also, the mailbox must exisit on the Exchange Server.

Here is a technote, which explains how to restore

turtlefence's picture

Hi Jaydeep,

We aren't restoring to a pst, we are trying to restore to a mailbox created just for this reason.

Once restored, the user will be given permission to the mailbox, then it can be deleted later.



lmosla's picture


is the logon account for the Backup Exec Remote Agent service on the Exchange server running as a Local systems account?

also make sure all of your updates are installed and pushed out to the Exchange Server and all remote servers

turtlefence's picture


The Remote Agent was running as the Local Systems account, I have tried changing this between both the backup service account and the domain administrator, both without luck :(

Backup Exec is also up to date according to live update.

Jaydeep S's picture

Make sure that the mailbox that you have created is not hidden. Also, you need to activate the mailbox by sending and receiving an email from and to it.

Also, is the mailbox connected to user?