Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Problems upgrading BE 11d to 12.5 on Windows Server 2003

Created: 12 Mar 2013 • Updated: 09 May 2013 | 3 comments
This issue has been solved. See solution.

Hi

I've been given the task of upgrading our BE software to the latest 2012 version, and was wondering if somebody would be able to advise on what's best to do?  I've never done anything like this before and don't really know where to start, so any advice would be a massive help!  (I've only been in this Trainee position since December so really would appreciate any pointers.) 

We currently use verision 11d on Windows Server 2003, and believe I need to upgrade to version 12.5 before I can do a direct upgrade to 2012.

First of all I mirrored our Live backup server on to a Virtual Machine, so I could test everything first before upgrading our Live system. I downloaded and installed version 12.5 on the virtual machine, but have the following issues:

1.)  Unable to load DLL 'bemsdkwrapper': The specified procedure could not be found. (Exception from HRESULT: 0x8007007F.

The below error messages pops up when trying to open the upgraded BE 12.5, sticks like this and then closes down.

 

After this happened, I went in to the Event Viewer to see if I could find more information.

Using this information, I have looked on this site for a solution but haven't had any luck.

I've tried un-installing and re-installing the .NET framework which comes up with the following, even though it's installed!!! (As shown below.)

 

I've tried doing a repair in Add/Remove Programs on BE 12.5 and then a reboot, and still no joy.  We've also deleted the Virtual Machine and started all over again, but we're still having the same errors and I'm not sure what else I can do!

Any help or advice would be greatly appreciated.

Thanks 

 

Operating Systems:

Comments 3 CommentsJump to latest comment

CraigV's picture

...have you tried to upgrade to BE 2010 R3 instead of BE 12.5, and then upgrading to BE 2012? You can get the ISO on the link below:

http://trialware.norton.com/files/fc/Backup_Exec_2010_13.0.5204_MultiPlatforms_Multilingual_DVD.iso

Do you get a similar error if you try install a clean version of BE 12.5 on another VM? If so, could be a corrupt ISO that you downloaded!

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

SOLUTION
pkh's picture

Given the fact that you have to do a multi-stage upgrade to BE 2012 and there are so much differences between BE 11d and BE 2012, it might be easier to just take note of your job settings and then uninstall BE 11d and then do a fresh install of BE 2012.

Before you upgrade to BE 2012, you might want to read my article

https://www-secure.symantec.com/connect/articles/p...

ticketyboo's picture

Hi Both

Thank you for responding to my query.

I've raised a case with Symantec. The Agent I spoke to watched me install 12.5 on our Live system and saw the problem I was having. Like CraigV suggested, he has told me to download 2010 R3 and we will take it from there... Fingers crossed :)