Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Process Automation Error

Created: 14 Nov 2012 • Updated: 26 Aug 2013 | 7 comments
This issue has been solved. See solution.

I just finished a fresh installation of Service Desk 7.5 and am unable to access "Process Automation" under the Admin tab.  I get the following error:

Process Manager Error
 
Message: Declaration referenced in a method implementation cannot be a final method. Type: 'SD.AutomationRules.Incident.IncidentRulesetArguments'. Assembly: 'SD.AutomationRules, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.
Log:
at System.Reflection.CustomAttribute._CreateCaObject(Void* pModule, Void* pCtor, Byte** ppBlob, Byte* pEndBlob, Int32* pcNamedArgs) at System.Reflection.CustomAttribute.CreateCaObject(Module module, RuntimeMethodHandle ctor, IntPtr& blob, IntPtr blobEnd, Int32& namedArgs) at System.Reflection.CustomAttribute.GetCustomAttributes(Module decoratedModule, Int32 decoratedMetadataToken, Int32 pcaCount, RuntimeType attributeFilterType, Boolean mustBeInheritable, IList derivedAttributes) at System.Reflection.CustomAttribute.GetCustomAttributes(Assembly assembly, RuntimeType caType) at Symantec.Workflow.RulesEngine.RuleFactory.RegisterAutomationLibraries() at Symantec.Workflow.RulesEngine.RuleFactory.get_Services() at LogicBase.Ensemble.RulesEngine.AvailableServices.Page_PreRender(Object sender, EventArgs e) at System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) at System.EventHandler.Invoke(Object sender, EventArgs e) at System.Web.UI.Control.OnPreRender(EventArgs e) at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Any help would be greatly appreciated.

Thanks,

Eric

Comments 7 CommentsJump to latest comment

TGiles's picture

Did you perform the install on a new machine or did you re-use an existing ServiceDesk machine? The SD.AutomationRules dll file mentioned is no longer in existence in ServiceDesk 7.5. All of the dll files pertaining to Automation rules have been renamed to start with Symantec.ServiceDesk.

EricH_'s picture

I uninstalled 7.1 from the server and deleted the process manager database (off box) since we never went live with 7.1.  I guess this is probably caused by some residual files from the old installation then?

Will Yalland's picture

You're correct, some residual files remain even after running the uninstall.

The error you're getting here is the same I received when I tried to get this up and running in a test environment for evaluation.

If you're going for a fresh install you'll want to remove the entire process manager directory and clean out the temp folder of the user accoutn being used to install service desk.

SOLUTION
TGiles's picture

You may also want to look in the ProgramData folder and make sure any ServiceDesk or Workflow folders are removed as well.

gmirabella's picture

Exactly same problem here. I'm removing all traces of old installation. I will give you news when I'm done.

gmirabella's picture

Thanks for all!

You must delete all traces of old installation and everything works.

EricH_'s picture

Tha worked for me as well.  Thanks so much!