Video Screencast Help

Progressively Slower Backups

Created: 29 Mar 2010 • Updated: 30 Sep 2010 | 3 comments

I know this topic has been discussed ad nauseum.  But, for some reason, I truely think I have something different (don't we all!).

We have been taking weekly full backups for a few months now, resetting archive bit and all this wonderful stuff (I don't think that it all really matters with this scenario), nothing has changed except for Windows updates, and the backups are taking progressively longer and longer each week.  Now, this may sound normal to some, but this has gone from a backup of just over 900 GB in 24 hours (which I am fine with) to 970 GB in 57 hours.  The 24 hour job had a rate of 972 MB/min and now we are down to 472 MB/min.  When looking at all of the backups, I can't really place my finger on any one big jump, so I don't think I can really go back and say "this all started here" type of thing.

Adding an extra 70 GB and an extra 33 hours just seems a little excessive to me (this is all backing up to disk as well, backing up directly to tape is a tad faster, but not much).

Any suggestions or do I need to provide more info?

I'm using BE 12.5.

Comments 3 CommentsJump to latest comment

Ken Putnam's picture

D2T?

D2D? 

If the latter, when was the last time that you defragged the target disk?    Do/did you use the option to  "Allocate the maximum size for backup-to-disk files"

If this response answers your concern, please mark it as a "solution"

JHudson's picture

We use both.  Our weekly backups are D2D and then are spun off to tape for offsite removal.  Our monthly backups are D2T.  This runs a tad faster but not much; maybe 200 MB/min faster.

I have never defragged the target disk on the D2D and quite frankly I'm not sure how.  All I have is a web interface into the system.  This does have dedup running on it though; I would imagine that would affect the transfer rate some, but not that much - I wouldn't think anyways or am I wrong on that assumption?

I'm not sure where to set the "allocate the maximum size for backup-to-disk files."

The configuration for the drive for this D2D is as follows:
     Block Size: 64 KB
     Buffer Size: 64 KB
     Buffer Count: 10
     High water count: 0

Unchecked:  Read single block mode
Checked:  Write single block mode
Unchecked:  Read SCSI pass-through mode
Checked:  Write SCSI pass-through mode

Thanks for your help.

Ken Putnam's picture

I'm not sure where to set the "allocate the maximum size for backup-to-disk files."

This isn't set on the device, but in Tools\Options.  It was added to help avoid the absolutely horrendous fragmentation created in v10d and early v11.    Rather than allocating "chunks" of the max file size, this forces BE to allocate the entire BKF file at one time. 

I  have never defragged the target disk on the D2D and quite frankly I'm not sure how.

I'd sure look into this.  The "progressive" part of your description suggests fragmentation rather than a bad setting someplace

If this response answers your concern, please mark it as a "solution"