Video Screencast Help

PSExec hanging from Execute Process and Wait

Created: 29 Jun 2012 • Updated: 02 Jul 2012 | 3 comments
This issue has been solved. See solution.

Is anyone having any issues with PSExec running from Workflow? It's seemed to stop working for me all of a sudden when calling iisreset. The command actually completes but the process is still running from the task manager. It works fine from Debug from my account as well as the service account so I know it's not the accepteula issue. Anyone have any ideas?

 

Server is 2008 R2 x64

7.1 Sp2

command is psexec \\computername iisreset

 

I've tried with options -i -s with no luck.

 

A google search suggests this is somewhat common with c# programs that call this.

Comments 3 CommentsJump to latest comment

rdvanorman's picture

I haven't used it in a workflow but I have had issues with it in just a batch file and had to do a check for the service and loop until it killed it.

OOPs.. my bad thats for PSService and PSKill..

 

Rob Moore's picture

Hiow are you executing the process? Could it be the License agreement is popping up? If it is is hidden you won't see it.

I had a similar problem. I had to execute the program using a named service account. I logged in as that user and executed it one time to accept the agreement. After that it ran fine.

 

rob

b3tts32's picture

Though I'm not sure why it randomly stopped working all of a sudden after about a month of running fine. I added the parameter cmd /c which made the command line psexec \\computername cmd /c iisreset. 

SOLUTION