Video Screencast Help

PST import with EVPM when DAG server does not have CAS role

Created: 05 Nov 2012 • Updated: 05 Nov 2012 | 3 comments

Hi all,

I am facing some issues with pst imports. I am hoping you might be of assistance.

The process we are trying to achieve is the following:

  1. Single dedicated service account exports mail from Lotus Notes to PSTs (one per user)
    1. PSTs are not marked, given that all generated from the same service account
  2. EV processes those PSTs (stored in a central location) and imports them to the users archives. It pushes the stubs to the mailbox.

 

To do this, I created a simple evpm ini file, which is working fine when the Exchange server is both CAS & Mailbox server.

 

The issue I have is the following:

  • We have dedicated CAS and DAG production servers
  • When I run “evpm -e dag01 -m evaultmbx@domain.com -f C:\a.ini” I get:
    • Error creating privileged MAPI session (normal)
  • When I run “evpm -e cas01 -m evaultmbx@domain.com -f C:\a.ini” I get:
    • 02:26:16 PST Migration failed. Check the Application Event log on the computer running the MigratorServer for possible errors.
    • The eventlog contains the following:
      • Processing aborted due to an unrecoverable error.
      • (…)
      • Exchange Server\Mailbox: cas01\/o=LOBIZ/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=userf8325186

I tried to google this issue, but was unable to find anything useful. Do you have any idea on how to make this work?

The strange thing is that the process completes successfully when using a user/server/site when the server has both roles (cas & mailbox), but not with dedicated roles servers.

When using the wizard, the import completes successfully, so I am guessing I am missing a configuration parameter, but I cannot find which one in the documentation.

Thank you very much for your help.

Kind regards,

letienne

Comments 3 CommentsJump to latest comment

ZeRoC00L's picture

Have you set the regkey in this Technote:

http://www.symantec.com/business/support/index?page=content&id=TECH164054

Indeed you need the second command, to the CAS server.

If this response answers your concern, please mark it as a "solution"

letienne's picture

Hi,

I just tried with the key mentioned, and the issue remains the same.

I forgot to mention in my inital post that the items gets archived ok, but the stubs are never pushed to the user's mailbox.

Thanks !

Before anyone asks, here is my .ini content:

[directory]
DirectoryComputerName = gvaevault01.domain.com
SiteName = EV

[PSTDefaults]
ServerComputerName = gvaevault01.domain.com
MigrationMode = Process
ShortcutMode = MailboxShortcuts
SetPSThidden = false
SetPSTReadOnly = false
CompactPST = false
DeletePST = true
IncludeDeletedItems = true
PSTLanguage = Western European

[PST]
VaultName = First Last
ArchiveName = First Last
FileName = E:\PSTs\test_import.pst
MailboxDN = /o=LOBIZ/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=userf8325186

letienne's picture

I found a very ugly workaround (which is not acceptable in production, but worth mentioning):

  • In C:\windows\system32\drivers\etc\hosts, put:
    • 10.X.Y.Z dag01
  • With 10.X.Y.Z being the CAS IP
  • Call evpm.exe -e dag01

This apparently allows EV to import everything and push the stubs properly