Video Screencast Help

Pubkey.crt and Default Ghost Console

Created: 06 Aug 2013 • Updated: 08 Aug 2013 | 4 comments
This issue has been solved. See solution.

I installed Ghost Console on a 2008r2 server that also serves as a domain controller. I have not been able to get it to configure clients to join the domain, so in an attempt to troubleshoot the issue, I have uninstalled the console from the server, installed it on a separate machine, and I am trying to create a new, independent, fresh ghost environment to attempt to figure out what is causing the domain-add failure.

Everytime one of my new clients re-boots, it sits spinning its ghost-gears looking for that console that is no longer installed on the server. I have re-generated a new pubkey.crt and copied it over to the clients ( these are clients I didn't even have on the old server btw) and that didnt work. I can only get it to work by either re-installing the client and therein specifying the new server machine name, or by editing the pubkey.crt to contain only the new server machine name.

Either of these solutions will only work as long as the computer is not rebooted. You can see that is an asinine stipulation for proper function in ghost. I am sure there is a fix, please help an admin out. <<ready to destroy computers>>

Operating Systems:

Comments 4 CommentsJump to latest comment

EdT's picture

Your solutions are pretty much what needs to be done. Removing and re-installing the client should be the simplest solution, but make sure any remaining registry keys associated with Ghost are deleted before reinstalling.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Terry BU's picture

when the client reboots, are you rebooting into the WinPE, or rebooting regularly back into Windows?  I just want to get an idea of where the cert is reverting

theunfrailhale's picture

It was some stupid DNS issues that I was having on my ghost console machine. Totally my error, I had an alternate DNS server from our local domain one installed. I think that the clients weren't resolving properly due to that fact. Also the console was on a fairly weathered OS install which had seen some virus removals etc, and I finally just wiped and re-installed a fresh copy. All client locating issues are now operating as normal.

Thanks for the input gents. Its been a rough week...