Video Screencast Help

Public folder archiving stopped on EV9

Created: 15 Jan 2014 • Updated: 26 Mar 2014 | 16 comments
This issue has been solved. See solution.

Hi

About a week ago Archiving of Public Folders stopped.

Evault 9.4 on windows 2003 R2 sp2 and exchange 2003 sp2 on w2k3 R2 sp2.

Using dtrace I see this errors for every public folder.

154 09:52:47.616  [7516] (PublicFolderTask) <6380> EV:M {CMailboxHelper::CreateProfileAndSessionEx:#841} Setting up MAPI profile [VaultMbxAgent-HKEXC2-6380-1389775967-0-616-0]
155 09:52:48.037  [7516] (PublicFolderTask) <6380> EV:M {CMailboxHelper::CreateProfileAndSessionEx:#1005} MAPI Profile [VaultMbxAgent-HKEXC2-6380-1389775967-0-616-0] successfully created.
156 09:52:48.037  [7516] (PublicFolderTask) <6380> EV:M {CEVMAPIMutex::ReleaseMAPIMutex:#147} Releasing exclusive profile lock.
157 09:52:48.084  [7516] (PublicFolderTask) <6380> EV:M CPublicFolderAgentTask::CheckFolderMarkIncludesExchangeServer - Checking Folder Mark on Path [�INFORMATICADIENST�CSYSMELD�ARCHIVERING EVAULT]
158 09:52:48.084  [7516] (PublicFolderTask) <6380> EV:H HrMAPIOpenFolderExKvs - COM error caught 0x80070005
159 09:52:48.084  [7516] (PublicFolderTask) <6380> EV:M CPublicFolderAgentTask::CheckFolderMarkIncludesExchangeServer - Exchange Server Name property not found on hidden message, attempting to add it
160 09:52:48.084  [7516] (PublicFolderTask) <6380> EV:H HrMAPIOpenFolderExKvs - COM error caught 0x80070005
161 09:52:48.084  [7516] (PublicFolderTask) <6380> EV:M CPublicFolderAgentTask::CheckFolderMarkIncludesExchangeServer - Checking Folder Mark on Path [�INFORMATICADIENST�TIKKLOK]
162 09:52:48.084  [7516] (PublicFolderTask) <6380> EV:H HrMAPIOpenFolderExKvs - COM error caught 0x80070005
163 09:52:48.084  [7516] (PublicFolderTask) <6380> EV:M CPublicFolderAgentTask::CheckFolderMarkIncludesExchangeServer - Exchange Server Name property not found on hidden message, attempting to add it
164 09:52:48.084  [7516] (PublicFolderTask) <6380> EV:H HrMAPIOpenFolderExKvs - COM error caught 0x80070005
165 09:52:48.100  [7516] (PublicFolderTask) <6380> EV:M CMailboxHelper::DeleteProfile(VaultMbxAgent-HKEXC2-6380-1389775967-0-616-0): 0x0

I've add the vault account as owner to the public folder (and subfolders).

I believe the archiving stopped after windows updates, but I might be wrong.

Mailbox archiving works (same servers, and accounts used).

It seems to be the same problem as here: https://www-secure.symantec.com/connect/forums/ev9-no-new-items-public-folder-archiving

Please help.

Operating Systems:

Comments 16 CommentsJump to latest comment

GertjanA's picture

Hello Andre,

Is the password for the VSA recently changed? Could it be the account is locked out?

the error code indicates a permission issue. What you could try initially is to reset the account in the VAC. (login as VSA, ricghtclick Directory, Service Account, type in password again, apply, ok) when done, restart the Admin service on all EV-servers.

Check again.

Thank you, Gertjan, MCSE, MCITP,MCTS, SCS, STS
Company: www.t2.nl

www.quadrotech-it.com

www.symantec.com/vision

Andre Peeters's picture

Hi GertJan

No, the password was not changed, and the accound is not locked out. I've tried re-entering the password in VAC, but is does not help. btw the same account (and password) is used for mailbox archiving and those are still being processed.

btw: there are no errors in the eventlog.

regards.

JesusWept3's picture

As gertjan pointed out, its a permissions issue so the EV Admin account probably had its full access permissions revoked on the public folders

Andre Peeters's picture

Hi JesusWept3

I've (re)checked the permission. The EVAdmin account has owner rights on the public folder all the way from the top thru the sub folders. The account is not locked out.

What else, is there in the DTrace something else I should look for?

Thanks in advance

André

JesusWept3's picture

i think you'll need more than owner rights on it , i think you'll need actual Information store rights
What i would suggest is open the VAC , go to tools -> advanced features, right click the EV Server that runs the task, go to Deployment Scanner, uncheck "Gather information for support" and ensure Do Not Set Configuration Options is unchecked, then in the exchange servers list on the first page, add the exchange servers you're targeting for PF and let the DS run

You may find that it might complain about send as/receive as permissions

You may want to add the Hidden Security Page and then just look specifically at that Exchange Server or the information store in question and do an effective permissions against the EVAdmin account

Andre Peeters's picture

Hi JesusWept3

I ran the deploymentscanner and got no errors.

I got an OK on the exchange part. the EV Admin has Send As and Receive As rights.

I think the permissions on the exchange server are oké as well.

Regards

plaudone's picture

Is the  FixOrphanedShortcut registry key being used?  

Also, looking into issues with the same error it is shown as resolved in 9.0.5 relating to MAPI "lie mode" and establishing connections.  

Andre Peeters's picture

Hi Plaudone

Sorry for the delay, things are busy for the moment.

No, the FixOrphanedShortcut is not used. Is it part of EV 9.0.4 ?

What does this key do? i'll guess Fixing Orphaned shortcuts, but which orphaned shortcuts. Normaly they are cleaned up by EV itself.

Where does this key go ?

 

plaudone's picture

Andre,

If the key was in place then it could potentially be an issue.  

http://www.symantec.com/docs/TECH206042

HKEY_LOCAL_MACHINE\SOFTWARE\KVS\Enterprise Vault\Agents\FixOrphanedShortcut

Other than that the suggestion would be to upgrade to 9.0.5.  

http://www.symantec.com/docs/TECH204715

Andre Peeters's picture

Hi All

I'v upgrade the server to EV9.0.5 (and to Windows 2008 r2), but the public folders are still not archived.

No errors are logged in the eventlog.

The vault admin account is an view only administrator on exchange.

In exchange manager, the vault admin has full admin in the admingroup on the exchange server

on the public folders top level, the vault admin has full admin

on a public folder and subfolder i've added the vault admin as owner on the client permission, but this does not help. On this public folder in the directory rights the vault admin has only read access (read, list, read permissions,  execute, list object) and in administrative rights the vault admin has only "view information store status" (the last two are inherited). Are these last settings enough?

Tia

André

I've added a dtrace log to this post

AttachmentSize
DTrace.7z 30.21 KB
plaudone's picture

If you resart the EV Storage and Task Controller service does it work for a time?  

What is the Outlook version on the EV server?  

Are there other archiving tasks that work on that EV server? 

Andre Peeters's picture

Usually I restart all services and yes, that helps sometimes for a (short) time.

Every night, the services are stopped to take a back up of all the data. Starting the services afterwards does not help.

The outlook version is 2007 (12.0.6665.5003) sp3 MSO (12.0.6683.5000)

Mailbox archiving keeps on working without problems.

 

 

plaudone's picture

How many tasks on the EV server and how many threads per task?  

Is the Public Folder target the same Exchange server as the mailbox archiving target? 

How many mail profiles show up when the issue occurs?  Can you delete the older ones and test to see if that helps.  This looks to be a MAPI connection issue as seems to occur over time.   

There were adjustments to this type of connection in EV 10.0 as well that have resolved similar Public Folder issues. 

Andre Peeters's picture

The number of threads per task is still on the default setting (5 I believe).

I used to have 4 tasks (2 for mail, 2 for public folders), early this year we added more public folder tasks. After a few days, things went wrong. Last thursday, I went back to only 2 public folder tasks. This seemed to help a bit. One of the two tasks kept working, the other has worked till saturday evening but has don nothing on sunday (where it should have).

The task that kept working has only 1 public folder, the other has about 10 public folders.

The public folder target is the same exchange server as the mail archiving target. (We have 2 exchanges server, both with mail and public folders).

There are 24 mail profiles. That seems much?

Upgrading to EV10 is planned for later this year.

 

plaudone's picture

This issue looks to be communication to the DC at times causing an issue.  You could try to restart the tasks regularly to see if that helps.  Also, confirm that network has no issues.   In some cases a re-install of Outlook has helped.  

These are the key lines from the Dtrace:
 
3238 14:00:20.336 [6420] (PublicFolderTask) <9668> EV:L {HrMAPIOpenMsgStoreKvs:#50} Opened msg store [0x0]
3239 14:00:20.340 [6420] (PublicFolderTask) <9668> EV:H {HrMAPIOpenFolderExKvs:#231} COM error caught [0x80070005]
 
A change was made in 10.0.3 to avoid this path a provide a more reliable method of obtaining the information.  You may still experience issues at times until the upgrade to 10 is complete.  

SOLUTION
Andre Peeters's picture

Hi All

I've opened a case with symantec and together we managed to fix te issue. Their suggestion was to upgrade to 10.0.4. After this upgrade we were able to archive public folders (again).

Restarting the services (as plaudone suggested) helped most of the time.

thanks all for your time.

André