Video Screencast Help

Publishing a Workflow that executes batch files

Created: 21 Oct 2009 • Updated: 04 Jan 2013 | 5 comments
This issue has been solved. See solution.

 I've created a workflow that calls batch files to execute vb scripts to do administrative tasks.   The workflow works great in debug mode.  The issue I have in workflow 6.5 is when I publish the workflow it fails immediately when opened.  I know this is probably a permissions issue when executing the scripts.  My question is how do I configure the workflow to run under a administrator account so that the batch files can execute?  Do I do this in IIS or is there somewhere inside of workflow that I set this?

Comments 5 CommentsJump to latest comment

reecardo's picture

Have you tried marking up the permissions of the VD in IIS (i.e. making sure there's execute permissions on the folder)?

Rob Moore's picture

When you run a workflow, it executes any scripts using the Network Service account, which has little if any permissions.

By changing the appliction pool identity  (or createing a new one) with an actual named user, all your scripts will run under that user context and permissions.


sgreer2002's picture

 Ok - I've created a new application pool for the workflow and added a service account with administrator rights as the identity.  I've also added this to the IIS_WPG group.  Now when I run the workflow it asks for authentication.  No matter what user I put in the logon prompt it fails.  I'm using windows authentication for the site and don't want to use anonymous authentication. If i click browse site in IIS the workflow works fine. If I hit the site from another computer it prompts for logon information and fails.  Any ideas?

sgreer2002's picture

1. set the Service Account as the identity in the new application pool
2. Add the Service Account to IIS_WPG group.
3. Either set a SPN or set the NTAuthenticationProvider to NTLM.  You can find the steps here.;EN-US;871179