Video Screencast Help

PureDisk Dedup pool problems

Created: 20 Nov 2012 • Updated: 20 Nov 2012 | 4 comments
This issue has been solved. See solution.

I had a Windows 2008 R2 server running NetBackup 7.5.0.1 as a master/media server used at a remote site to receive AIR and it was working as expected with a PureDisk Deduplication Pool.

Long story short, the server had to be rebuilt. I had previously exported my license keys from this system, so now I have the same Windows 2008 R2 server with a clean install of NetBackup 7.5.0.4 on it. I have added the previous license keys back in to the new install.

The problem I am now having is that I cannot add a PureDisk Deduplication Pool again. When I add a new PureDisk Deduplication Pool storage server to the new build, that completes successfully. The problem is that I cannot add a disk pool to this storage server using the wizard. I choose PureDisk as the type and then select the storage server. When it gets to the Select Volumes screen I have no options.

 

Any ideas on how to proceed?

Comments 4 CommentsJump to latest comment

Mark_Solutions's picture

Is there already a disk pool for that server left in the NetBackup configuration somewhere from the previous installation?

Is this actually PureDisk or should it be MSDP?

If PureDisk what is it located on and have you added the media server as a valid server with access to it under the credentials - storage servers section?

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

brian.atkinson's picture

Hey Mark - thanks for the response.

I don't think there are any remnants. Running "nbdevquery -listdp -stype PureDisk -U" returns:
no disk pools found!

I am fairly confident it was a PureDisk pool before. The other master/media server that replicates to it is definitely using PureDisk.

If I select the Credentials->Storage server, in the right pane the the storage server is listed as PureDisk and in the lower pane the same server is listed in the Media Servers section.

Mark_Solutions's picture

So is it actually PureDisk?

If the storage is configured on the media server itself then it is MSDP (even though NetBackup tends to call it puredisk)

If you have a seperate physical unit somewhere (a PureDisk Server or appliance) then it is puredisk

If it is all on the Windows Server then try running the wizard again but select MSDP instead

Hope this helps

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

SOLUTION
brian.atkinson's picture

Thank you Mark!

It was MSDP - I just got caught up in the wording of everything and thought it had to be PureDisk. I have a pool of direct attached storage, so it definitely isn't PureDisk. I created the MSDP and everything is now working (including replication) again.

Thank you again - I really appreciate it!