Video Screencast Help

PXE Boot across VLAN

Created: 07 Dec 2012 • Updated: 19 Dec 2012 | 5 comments
This issue has been solved. See solution.

Any help is much appreciated.

We have just deployed Altiris 7.1 (NS) in our environment for the first time.

Previously we used WDS and DT2010 and was able to PXEboot across VLANs just with the DHCP options set.

NS is on a separate VLAN from the DNS and DHCP servers.

I have set the DHCP option 66 (Boot server host name) with ip address of NS and DHCP option 67 with the Bootfile name as BStrap.0.

I am unable to boot from the other VLANs only from the VLAN that contains NS.

The network engineer refuses to add ip helper addresses to gateways. How can we PXE boot without IP helper addresses on the routers?


Comments 5 CommentsJump to latest comment

Nelo's picture

here u go. read the force mode part that is what u want. the first link is the theory behind PXE and the second link help with the hex part of force mode.

Article URL


fabian.szalatnay's picture

Hello Bish

You've got 2 possibilities to make it work....


- Configure the IP of your Altiris PXE Server as IP Helper for every subnet

- remove ALL PXE DHCP Options


Check out the forced mode as Nelo mentioned.

- no need of IP Helper

- but you will configure complicated DHCP options for some or all subnets

Good Luck

joegman's picture

Here is what I used to solve my problem.  This is pasted from another thread. Hopefully this helps you some.  I am new to Altiris and I do not want to spread mis-information.  My NS is on the same VLAN as the DHCP server, but my task server is on a different VLAN; my task server runs the PXE services.

Forgive me if this has been resolved already, but you have to configure your DHCP server.  I used thePXEForcedMode_Utility to help.  I'm probably slow, but it took me a whole day to work it out.  Option 43 was the most difficult thing for me to work out (I tried in vain at first before using the PXE Forced Mode Utility).

My DHCP Server options:

43 (I won't list the value because yours will be different)
60 PXEClient
66 (IP address of your server running PXE services, in my case my local task server.  FYI, you have to start the services manually: interface, server, nssignal, mtftp)
67 Bstrap\x86\bstrap.0  (dig around on your server and you will find this path and file)

Nelo's picture

Yes, all the posts on this thread reference to the same articles and solutions :)

I would suggest reading the white paper to get a better idea how "Force Mode" works.

hbishman's picture

Thanks a million everyone. I used the forced mode and everything is working fine with PXE.