Video Screencast Help

Pxe Boot With Altiris 7.5

Created: 08 Oct 2013 | 10 comments

I upgraded to Altiris 7.5 but now when i try to pxe boot a desktop i am receiving a no boot filename received. 

I had a look at the old pxe services but they have been renamed to something else.  Anyone else had these problems and know the solution?

Operating Systems:

Comments 10 CommentsJump to latest comment

md investigate's picture

Hi,

are the services running? The services are now called Symantec Network Boot Service (PXE and BSDP) and Symantec Network Boot Services (TFTP).

Did you created the new preboot environment?

Regards 

 

DSLAM's picture

Both the new services are running, i have clicked on recreate preboot environment but nothing seems to happen. 

Tried manually re-creating the preboot environment with the bootwiz program but it fails to load. I might try a repair of the install in case something has happened. 

md investigate's picture

Hi,

is the bootwiz.exe process appearing in windows taskmanager? Did you created a new preboot configuration after upgrade? Is anything logged in logviewer?

 

Regards

DSLAM's picture

no the bootwiz process never starts, but i have found that my agents are not registering with the NS server so it is never picking up the job. 

I will try and diagnose the registration problem first and see if that resolves my pxe boot issue. 

Tony.Richmond's picture

I have similar issue with the new an improved NBS, getting PXE-E32: tftp open timeout message. Have resintalled the SNBS from the Siet Servers menu, recreated the Boot Environment but I cannot see any service installed releating the 'Symantec Boot Services' where should it be, what exe is used for it, what runs TFTP services.

Was working perfectly under 7.1 SP2. I can think of more than 7.5 reasons NOT to upgrade to 7.5 right now!

 

 

ajpaisley's picture

In my case, I had to rebuild and when I did, I was updated to 7.5 automatically with out asking.

I looked at the services and did not see any reference to the "Symantec Network Boot Service (PXE and BSDP) and Symantec Network Boot Services (TFTP) in Servcies".

I did configure the PXE stuff in settings but yet, I still do not see the the service mentioned nor can I boot to PXE.

Any clues would be great or even better, is there a updated How To sheet that walks you thought the proccess?

md investigate's picture

Hi,

the services are called SymantecNetworkBootServicePxe and SymantecNetworkBootServiceTftp. They are installed through site server services installation. Have a look in site server settings and find out if your servers have this "role" tagged? The function of the nbs services should work without any preboot configuration. The further configurations needed for the nbs are found in settings --> deployment --> NBS General Settings and NBS Global Settings.

What are your errors while booting? Is the correct server faced? Are there infrastructure issues? Any ip helpers missing or misconfiguration of dhcp options? Please keep in mind that all prerequisities for network are the same as in 7.1.

Did you had a look for logging? Please have a look in C:\Program Files\Altiris\Altiris Agent\Agents\Deployment\Logs and C:\Program Files\Altiris\Altiris Agent\Agents\Deployment\SBS. There are some logfiles and give you some feedback on status of the services etc.

Regards

jpellet2's picture

I was writing up this long, drawn-out explanation on how you can manually install the PXE services if you need to (because we had to) until I found that the KB already has that information. Have you tried to remove then re-install the NBS services?

http://www.symantec.com/business/support/index?page=content&id=TECH211634

 

And a little more information on the timing of rebuilding your PXE images here which might help: 

http://www.symantec.com/business/support/index?page=content&id=TECH211409

Not sure if any of it is helpful but as I said, I needed to re-install the NBS services manually because the console wouldn't do it for me.

 

DSLAM's picture

Just a quick update to my original post, I had to completely uninstall the NS and re-install. i tried doing a repair install but it didnt work. 

 

I'm pretty sure my PXE boot problems was just a side effect of a bigger server side error where my client agents would not register including on the NS itself causing my pxe boot image to never be recreated as it could never receive the job. 

 

 

ajpaisley's picture

Hi All

This is what I have done to date.

1. Installed Altiris 7.5 and then rebooted.
2. Monitored the "C:\Program Files\Altiris\Altiris Agent\Agents" and I can see the Deployment directory and it contents. This took a long time.
3. Site server showed "Altiris1" was already created. Both Task server and NBS are installed.
4. I then created the Preboot Configurations "WINPE_x64".  Ran this all night and did not touch anything after it started.
5. When booting, I get the menu but when I hit F8, all I see is "Next Device" but the WINPE_x64 is not present becasue it does not show in the the PE instance in "Peeboot Configuration Status".'

Any help on this would be great.

--AJ