Video Screencast Help

PXE boot error: Memory Allocation system halted

Created: 10 May 2012 • Updated: 11 May 2012 | 3 comments
This issue has been solved. See solution.

 

Good Afternoon:
 
We have recently aquired a dozen or so HP 8200Elite PCs.  We are required to use Altiris to adapt them to our system.
 
The problem we are having is that:  whenever i try to boot from a PXE boot enviroment, the computer loads the drive, finds our deployment server whcih then  gives it an IP address..  but then, the pxe boot enviroment halts with the error:
 
memory allocation error
cannot load COMMAND, system halted
 
I have searched the Altiris Knowledge Base and have followed instructions  as per KB35816
 
Unfortunately, this has not worked.
I still get the same error.
 
On top of this, i have flashed the bios, to a previous version and its produced no change.
Thenk I changed it back.  Still not change.
 
I do not believe this computer to need extra memory, as it has 3Gb.
 
Does anyone have any ideas?  Has anyone found a solution after the config.sys file changes have not worked?
 
Thank you in advance for any help given.

Comments 3 CommentsJump to latest comment

bhawver's picture

I assume that you are using DOS as an Automation environment.  I would suggest moving to WinPE or Linux as you'll be able to take advantage of the faster throughput when imaging.

Also, someone else had this very issue and there was a thread about it a couple of years back.  It seemed to point to the OEM partition on the machine.  You might try removing all partitions from the drive and then seeing if you still have issues.

 

https://www-secure.symantec.com/connect/forums/memory-allocation-failed

Brian Hawver
Systems Engineer
Yaskawa America, Inc.

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads.

catfordtechie's picture

 

 i read a number of threads relating to this, and even followed the steps on KB35816 but it still wouldnt work..

also, moving our deplyment server to linux isnt something we can afford at the moment.. but thanks for replying to my question anyway, i thought i might not get any answer here because of how old altiris is!!

 

However, i did find the problem, as it was concernign an unidentified network card, and in the end, there is an update on the intel website itself.

 

So, for anyone else that has come here searching why altiris will not play ball with their new 8200elite pcs, the answer is that intel recomends downloading the GENERIC driver for Intel® 82579 Gigabit Ethernet Controller (which includes Support for Intel® 82579LM and 82579V Gigabit Network Connection).

If you search for that on the intel website, it takes you to the DOS driver, with the latest version (march 2012).

This driver has a new version of 'e1000odi.com’  which is the file that PXE was saying it could not load.

 

Combine this driver with the instructions on KB35816 and then it should (fingers crossed) work with no issues.  I know that, for me, i am now seting up computers with this.

Good luck everyone :D

SOLUTION
Sweeten's picture

Glad you got your problem solved. It was definitely an issue with DOS not having the proper NIC driver for the clients.  However you also must understand that when a previous poster suggested WinPE or Linux, this was not in relation to the platform of the DS itself but merely of the pre-boot environment. If these are installed/configured properly you can run automated imaging jobs via the Vista/7 PE kernel or via linux.  Both offer substantial bandwidth improvements over DOS, are more likely to receive NIC driver updates, and provide more fexlibility, such as using VNC to remotely check the status of an imaging client.  Of the 2, linux is preferred b/c of its lower overhead and much smaller initial client download (WinPE is over 300MB to each client every time you push a pre-boot environment job to them before the actual job is run). Both are significant upgrades, especially when considering the remote capabilities and that you can image drives up to twice as fast depending on network infrastructure and hard drive configuration/SAN.